Remove the Contact Info block

Bug #892684 reported by Kristina Hoeppner on 2011-11-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
Low
Jono Mingard
Mahara user manual
Medium
Kristina Hoeppner

Bug Description

Contact information is also contained in the "Profile Info" block and not only the "Contact Info" block. Why does the "Contact Info" block exist?

Mahara 1.4

Changed in mahara:
status: New → Triaged
importance: Undecided → Low
François Marier (fmarier) wrote :

We'll need to migrate the existing blocks to the profile info block, so this is not a trivial one. However, removing duplicate code sounds like a good thing.

summary: - "Profile Info" block lets you choose the same fields as in "Contact
- Info"
+ Remove the Contact Info block
Robert Lyon (robertl-9) wrote :

I've taken a look at a large site and on it there are:
     831 instances of the contactinfo block
81544 instances of the profileinfo block

So if profileinfo block does all the functionality that the contactinfo block does then we could look to remove the contactinfo block as being part of core.

What do others think?

Fine by me as long as the information is migrated as Francois wrote.

Robert Lyon (robertl-9) on 2013-11-19
Changed in mahara:
status: Triaged → Confirmed
milestone: none → 1.9.0
Jono Mingard (mingard) on 2014-02-27
Changed in mahara:
assignee: nobody → Jono Mingard (mingard)

Reviewed: https://reviews.mahara.org/3052
Committed: http://gitorious.org/mahara/mahara/commit/b5c9e316329eca254841783acbd0b7a5177d0349
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit b5c9e316329eca254841783acbd0b7a5177d0349
Author: Jono Mingard <email address hidden>
Date: Thu Feb 27 15:01:32 2014 +1300

Removed Contact info blocktype (Bug #892684)

Since the data storage format is virtually identical for Contact information
and Profile information, all Contact info blocks can easily be changed to
Profile info ones

Change-Id: I4844630745c2d12d06a76b70ad7fd624342833eb
Signed-off-by: Jono Mingard <email address hidden>

Aaron Wells (u-aaronw) on 2014-02-27
Changed in mahara:
status: Confirmed → Fix Committed
tags: added: usermanualupdate
Changed in mahara-manual:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Kristina Hoeppner (kris-hoeppner)
milestone: none → 1.9.0

Reviewed: https://reviews.mahara.org/3082
Committed: http://gitorious.org/mahara/mahara/commit/24e8700e93169bfae646ddd1e3601f48fd95d60e
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 24e8700e93169bfae646ddd1e3601f48fd95d60e
Author: Robert Lyon <email address hidden>
Date: Fri Mar 7 08:45:41 2014 +1300

Increment the artefact internal version number (Bug #892684)

Commit b5c9e316329eca254841783acbd0b7a5177d0349 incremented the
artefact.internal DB version, but not the human-readable version.

Have bumped the version to 1.2.0. Also removed the section of lib/db/upgrade.php
that tells it to upgrade the artefact.internal plugin, because that'll happen
automatically.

Change-Id: Ie4ac77db99bc9ab5dc2901810a1283158ad4735d
Signed-off-by: Robert Lyon <email address hidden>
Signed-off-by: Aaron Wells <email address hidden>

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
Changed in mahara-manual:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers