Feedback ratings are not exportable

Bug #731062 reported by François Marier on 2011-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Robert Lyon

Bug Description

The star ratings that were added recently to feedback are not exportable.

They need to be part of the Leap2A and HTML exports.

Did you already merge that into Master? I can only see that in the <insider knowledge>Moderation Online mode and not on the regular site</insider knowledge>.

the comment is posted now became a bug of its own at bug 731062

Changed in mahara:
milestone: 1.4.0 → none
tags: added: feedback
Robert Lyon (robertl-9) wrote :

The rating stars are exportable in v1.8 for standalone html but there is a problem with the exported star file being .gif but the css expects .png - due to change done to default icons

have added a patch for that issue:
https://reviews.mahara.org/#/c/2707

However the comment star rating does not look like it's been exported to leap2a file so that needs to be sorted

Reviewed: https://reviews.mahara.org/2707
Committed: http://gitorious.org/mahara/mahara/commit/13d4624abf18de3c5bf3fd4b805ed9ca9f672a49
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 13d4624abf18de3c5bf3fd4b805ed9ca9f672a49
Author: Robert Lyon <email address hidden>
Date: Thu Nov 14 09:54:39 2013 +1300

Export to html using wrong rating star image (#bug 731062)

Change-Id: I62e2669fb55c8504a08a13a8f559f2d471de2a7b
Signed-off-by: Robert Lyon <email address hidden>

Feedback can only be exported in HTML, but not Leap2A as the users don'tnecessarily exist in the new installation where the Leap2A file is being imported or the user ID is taken by someone else and then the feedback is attributed to someone incorrectly.

Robert Lyon (robertl-9) wrote :

Ah in that case, if stars can only be exported to html this problem is fixed :)

Changed in mahara:
status: Confirmed → Fix Committed
assignee: nobody → Robert Lyon (robertl-9)
milestone: none → 1.9.0
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers