Overriding start/stop dates in VIEWS not working

Bug #722475 reported by Anthony Ramos on 2011-02-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Richard Mansfield
1.3
High
Richard Mansfield

Bug Description

Mahara: 1.3.3
SunOS java 5.11
PHP 5.2.6
MySQL
Chrome 9.0.597.102, Mozilla 3.6.13, Safari 5.0.3

When you click on EDIT ACCESS in VIEWS the OVERRIDING START/STOP DATES do not seem to be working.

I made a view (created by user A) visible only to another user (called B) and B could correctly see that View when B was logged in.

Then I logged in as A and specified a date range in VIEWS/EDIT ACCESS/OVERRIDING START/STOP DATES that incorporated today's date (and therefore should still be visible). However, when I logged in as B I could now not see that view.

When I logged in as A and removed the OVERRIDING START/STOP DATES and clicked SAVE, B could then see the view once again.

Changed in mahara:
status: New → Triaged
importance: Undecided → High
milestone: none → 1.4.0
Changed in mahara:
status: Triaged → Fix Committed
assignee: nobody → Richard Mansfield (richard-mansfield)

Hi Richard and Hugh,

Can you reproduce this bug?

I should add that when I was on demo.mahara.org only a few minutes ago
and edited my view and added weblink access (secret URL) leaving its
corresponding From and To date boxes empty BUT setting the OVERRIDING
 From and To dates both set to a date in the past I could still access
the view using the link. That is the To date doesn't seem to be
working. I cleared the cache to make sure it wasn't displaying due to
a cached browser and it doesn't seem to be.

To see this bug you can login to demo.mahara.org and search for user
"anthonyramos" and see my TESTVIEW with from and to dates of: 11-
May-11 with the secret URL.

I'd be keen to hear if you can test this and reproduce it or not.

Thanks,

Anthony

On 31/03/2011, at 12:57 PM, Richard Mansfield wrote:

> ** Changed in: mahara
> Status: Triaged => Fix Committed
>
> ** Changed in: mahara
> Assignee: (unassigned) => Richard Mansfield (richard-mansfield)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/722475
>
> Title:
> Overriding start/stop dates in VIEWS not working
>
> Status in Mahara ePortfolio:
> Fix Committed
>
> Bug description:
> Mahara: 1.3.3
> SunOS java 5.11
> PHP 5.2.6
> MySQL
> Chrome 9.0.597.102, Mozilla 3.6.13, Safari 5.0.3
>
> When you click on EDIT ACCESS in VIEWS the OVERRIDING START/STOP
> DATES
> do not seem to be working.
>
> I made a view (created by user A) visible only to another user
> (called
> B) and B could correctly see that View when B was logged in.
>
> Then I logged in as A and specified a date range in VIEWS/EDIT
> ACCESS/OVERRIDING START/STOP DATES that incorporated today's date
> (and
> therefore should still be visible). However, when I logged in as B I
> could now not see that view.
>
> When I logged in as A and removed the OVERRIDING START/STOP DATES and
> clicked SAVE, B could then see the view once again.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mahara/+bug/722475/+subscribe

Hi Anthony,

The patch for this was supposed to be in the last lot of releases, but unfortunately I left it out.

Anthony Ramos (planetjupiter08) wrote :

Hi Richard,

My apologies but I am a bit confused as I have noted 2 bugs. Just to
clarify can you please confirm the following:

- Bug 722470 is a result of our version of PHP. To fix this we will
need to go to PHP 5.3 as there is no other fix. Is that correct?

- Bug 722475: Is a recognized bug and will be fixed by the following
patch:
https://launchpadlibrarian.net/71612198/0001-Fix-start-stop-date-overrides-bug-722475-bug-746182.patch

I have not installed a patch before. Can I simply add the lines with a
"+" and delete the lines with a "-" to the existing file: htdocs/lib/
mahara.php
to fix this bug?

Thanks,

Anthony

On 13/05/2011, at 2:08 PM, Richard Mansfield wrote:

> ** Changed in: mahara/1.3
> Status: Confirmed => Fix Committed
>
> ** Changed in: mahara/1.3
> Assignee: (unassigned) => Richard Mansfield (richard-mansfield)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/722475
>
> Title:
> Overriding start/stop dates in VIEWS not working
>
> Status in Mahara ePortfolio:
> Fix Committed
> Status in Mahara 1.3 series:
> Fix Committed
>
> Bug description:
> Mahara: 1.3.3
> SunOS java 5.11
> PHP 5.2.6
> MySQL
> Chrome 9.0.597.102, Mozilla 3.6.13, Safari 5.0.3
>
> When you click on EDIT ACCESS in VIEWS the OVERRIDING START/STOP
> DATES
> do not seem to be working.
>
> I made a view (created by user A) visible only to another user
> (called
> B) and B could correctly see that View when B was logged in.
>
> Then I logged in as A and specified a date range in VIEWS/EDIT
> ACCESS/OVERRIDING START/STOP DATES that incorporated today's date
> (and
> therefore should still be visible). However, when I logged in as B I
> could now not see that view.
>
> When I logged in as A and removed the OVERRIDING START/STOP DATES and
> clicked SAVE, B could then see the view once again.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mahara/+bug/722475/+subscribe

Hi Anthony,

Yes, you can add lines with '+' and remove lines with '-', that's basically what the patch program does. However, that fix is already on the 1.3 branch, so instead of applying the patch, you can just get a whole new tarball from here:

 https://gitorious.org/mahara/mahara/archive-tarball/1.3_STABLE

I'm not sure what's causing bug #722470, I'll write a reply on that bug report.

Anthony Ramos (planetjupiter08) wrote :

Hi Richard,

Is this tarball the latest stable version of Mahara?

Thanks,

A

On 16/05/2011, at 7:21 AM, Richard Mansfield wrote:

> Hi Anthony,
>
> Yes, you can add lines with '+' and remove lines with '-', that's
> basically what the patch program does. However, that fix is already on
> the 1.3 branch, so instead of applying the patch, you can just get a
> whole new tarball from here:
>
> https://gitorious.org/mahara/mahara/archive-tarball/1.3_STABLE
>
> I'm not sure what's causing bug #722470, I'll write a reply on that bug
> report.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/722475
>
> Title:
> Overriding start/stop dates in VIEWS not working
>
> Status in Mahara ePortfolio:
> Fix Committed
> Status in Mahara 1.3 series:
> Fix Committed
>
> Bug description:
> Mahara: 1.3.3
> SunOS java 5.11
> PHP 5.2.6
> MySQL
> Chrome 9.0.597.102, Mozilla 3.6.13, Safari 5.0.3
>
> When you click on EDIT ACCESS in VIEWS the OVERRIDING START/STOP DATES
> do not seem to be working.
>
> I made a view (created by user A) visible only to another user (called
> B) and B could correctly see that View when B was logged in.
>
> Then I logged in as A and specified a date range in VIEWS/EDIT
> ACCESS/OVERRIDING START/STOP DATES that incorporated today's date (and
> therefore should still be visible). However, when I logged in as B I
> could now not see that view.
>
> When I logged in as A and removed the OVERRIDING START/STOP DATES and
> clicked SAVE, B could then see the view once again.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mahara/+bug/722475/+subscribe

Well, it's just a tarball generated from the tip of the 1.3 git branch, so in a sense it's more recent than the latest 1.3.6 release: the version number will be set to something like 1.3.7-testing.

Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers