"Request to join this group" throws error on group homepage

Reported by Kristina Hoeppner on 2011-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Ruslan Kabalin

Bug Description

When I am on the group homepage and click on "Request to join this group", I get the error "Mahara: Invalid Parameter
A required parameter is missing or malformed. The 'returnto' parameter is not alphabetical only."

However, when I am on the Find Groups page, I have no problems getting to the message window where I can request membership.

On the group homepage "find" is missing at the end of the URL http://master.dev.mahara.org/group/requestjoin.php?id=24&returnto=

-> It should be ...returnto=find as far as I can see.

I classified this as high importance because users may get frustrated if they can't join a group and may not go to the Find Groups page to try from there.

Changed in mahara:
assignee: nobody → Ruslan Kabalin (ruslan-kabalin)
tags: added: bite-sized groups
Changed in mahara:
status: New → Fix Committed
Ruslan Kabalin (rkabalin) wrote :

Hi Kristina, for the group homepage we need returnto=view, it was missed in template settings. Fixed now.

Thanks for fixing this, Ruslan.

It worked with "find" for me so that's why I assumed it could be the solution. Having the proper word sitting there is of course better. :-)

Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers