'My Files' are not available when editing a group view

Bug #634835 reported by Antti Koskinen on 2010-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Richard Mansfield

Bug Description

Mahara version: 1.3

Configuring a file download block in a group view, you can select files under 'My File' tab. However, all the folders there are empty and if you come back to the parent folder, it shows files and folders owned by the group.

I think the problem is that it tries to find files using the group as the owner instead of the current user. I have included a patch which fixes the problem for me.

Antti Koskinen (antti-koskinen) wrote :
Changed in mahara:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Richard Mansfield (richard-mansfield)
milestone: none → 1.3.1

Thanks Antti, I've committed your patch, with minor edits to whitespace for consistency with the coding style at http://wiki.mahara.org/Developer_Area/Coding_guidelines

Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers