Distinction between Name and Profile not clear

Bug #620161 reported by Kristina Hoeppner on 2010-08-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Robert Lyon

Bug Description

I still have trouble clicking on the correct link and think and adjustment may be necessary.

When I click on my name, I am taken to my profile page as others can see it.

When I click on "Profile", I can edit my profile, but I would think that I could actually view it.

Having the name and "Profile" right next to each other is not ideal, I think, because they are almost the same, but not quite.

When I'm on my profile page (the view), I don't know how to get back to my dashboard -> Oh. I have to click on the Mahara logo.

I like that we have "Settings" instead of the username in the top right because that already lessens confusion.

What about the following:
- Include a link "Home" in the navigation links before the others.
- "Profile" (also in the tabs on the dashboard page etc.) links to the profile view.
- And somewhere we need a link "Edit Profile Information" to get to all that stuff. It could go next to "Edit Content" (though then people might be confused to distinguish between adding profile info and dragging that info into a view).

Any ideas?

Kristina,

I wonder whether we even need most of those links at all (I assume you're talking about the top links in the small view header). I think when I created that header I lazily just used the same variable that was holding the main top level site menu, so you just get the same stuff. But Paul & Evonne both think there are way too many links there. It would be good to cut it down to just one or two that are the most useful places to go when you're looking at a view.

For example, after looking at a view I quite often want to go to My Views, but almost never want to go to Edit profile or Groups. Maybe those two links could be removed altogether. (I agree about adding the 'Home' link, by the way).

R.

Changed in mahara:
status: New → Opinion

Hi Richard,

Yes, I am talking about the disappearing links on a view. :-)

Actually, I quite like to have (almost) all the links in that menu that I also see on the dashboard. That adds consistency because I don't have to think about to which page I need to go to get to all these links (It annoys me in Moodle, for example, that I could not reach the profile or logout from every page, for example). As they are not constantly there, but only appear when I hover over them, they are not like a big navigation.

Usually, I somehow find my way back to the dashboard before going into groups, but we don't know how others are using the navigation. They may actually jump directly from a view to a group or their profile. IT would be really good to get some real users to talk through the navigation before making tremendous changes like taking out most links.

Kristina

Changed in mahara:
status: Opinion → Triaged
importance: Undecided → Medium
milestone: none → 1.4.0
Sean Brennan (the-ioniser) wrote :

IS this still a bug? as the page heading has changed.

Good question, Sean. Thanks for revisiting this tracker item.

I had another look at it. The problem with Profile is not blatant anymore as the top navigation item is "Content". However, I still don't know how to get from my edit profile to the profile view page. Could we put a link on the edit profile page above the profile picture that reads:

"Please go to your Profile page [link to it] to arrange the information you wish to display to other users."

My issue with not having the Dashboard as link in the small navigation bar that is hidden most of the time continues to be there as I still need to know to click on the Mahara logo to get back to the dashboard. Now I even have an additional item in the navigation, my name, if I am not mistaken. Or has that been there all the time?

Sean Brennan (the-ioniser) wrote :

Is this sort of what you meant?
Please refer to attached image.

Should I make the text larger or force more space after it?

I also though of putting a link just after the "General" tab but that would require a modification of pieforms.

I would not introduce a larger font. We don't do that anywhere on Mahara. Right now it looks though as if we did not align the picture correctly because the bold text appears above. Could you please left-align it with the image so that it just starts above the image?

Do you link to the edit page for the profile page? I think I would prefer that instead of the display of the profile page so that they don't have to take the extra step of clicking on "Edit" because we want them to go to the edit screen when they need to arrange content.

We used to have the "View profile" in the tab and it was not ideal. I would not put it in the tabs.

Sean Brennan (the-ioniser) wrote :

commit for this here
http://www.gitorious.org/~ioniser/mahara/ionisers-mahara/commits/lp620161-distinction-between-name-profile

I did not make the text span across the top of the profile image as this would require to much fiddling.

Attached is an image of what it looks like now.

Changed in mahara:
assignee: nobody → Sean Brennan (the-ioniser)

This looks good. The message is not as prominent anymore which is regretful, but we don't work much with bold. Or did you take the bold out unintentionally?

Sean Brennan (the-ioniser) wrote :

The bold was taken out due to your suggestion.
The link also goes to the edit view page.

Changed in mahara:
status: Triaged → In Progress
Changed in mahara:
assignee: Sean Brennan (the-ioniser) → nobody
status: In Progress → Confirmed
Changed in mahara:
milestone: 1.4.0 → none
importance: Medium → Low
tags: added: usability
Robert Lyon (robertl-9) wrote :

Have added the patch to gerrit so that we can decide to accept/reject it there
https://reviews.mahara.org/#/c/2699/

Reviewed: https://reviews.mahara.org/2699
Committed: http://gitorious.org/mahara/mahara/commit/d0a1c0f0d70a018e934ed0632e4cdb15155e7f51
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit d0a1c0f0d70a018e934ed0632e4cdb15155e7f51
Author: Sean Brennan <email address hidden>
Date: Tue Nov 12 15:40:51 2013 +1300

Link from Content -> profile edit to Portfolio profile edit page (bug #620161)

An old patch that didn't get added to gerrit - not sure if it got
overlooked or is not needed anymore - so I'd thought I'd add
it and let others decide.

It adds a link on the Content -> Profile page to go directly to
Portfolio editing of your profile page.

Change-Id: I320ae1433b4ae8b79752c57b5e331d08e2a547cb
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: Confirmed → Fix Committed
milestone: none → 1.9.0
tags: added: nominatedfeature
Robert Lyon (robertl-9) on 2013-11-19
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers