Wall should send notifications on new posts

Bug #547333 reported by Nigel-catalyst on 2009-01-29
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Aaron Wells

Bug Description

As per subject. It doesn't at the moment.

description: updated
tags: removed: mahara-eduforge-feature-request
tags: added: wall
mahara (jpjounier) wrote :

There should be a notification when there's a new post on a user's wall.

Stéphane (smlavoie) wrote :

I don't think it is hard to implement... I'd like very much this feature to be added to next version. Is it possible?

I't s the second time somebody writes to me on my wall and it takes me more than a week to answer since i do not go on my own profile page everyday.

Thanks for considering!

Aaron Wells (u-aaronw) wrote :

It does seem like a bit of an oversight. And probably not that hard to implement. It would simply require adding an ActivityType to the Wall block. ( https://wiki.mahara.org/index.php/Developer_Area/Notification_Plugins_%26_Activities )

Gordon McLeod (g-mcleod1) wrote :

Worth noting, you can't add your personal profile page to a watchlist, so the other idea I had to get around this wouldn't work.
I've missed a few messages because of this as you don't tend to look at your own profile page once you've set it up.

Aaron Wells (u-aaronw) on 2014-05-09
Changed in mahara:
milestone: none → 1.10.0
tags: added: notifications usability
Changed in mahara:
assignee: nobody → Aaron Wells (u-aaronw)
Aaron Wells (u-aaronw) on 2014-09-10
Changed in mahara:
milestone: 1.10.0 → 1.11.0
Changed in mahara:
status: Confirmed → In Progress
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
milestone: 15.04.0 → 15.04.1
Aaron Wells (u-aaronw) on 2015-04-21
Changed in mahara:
milestone: 15.04.1 → 15.10.0
Aaron Wells (u-aaronw) on 2015-10-23
Changed in mahara:
status: In Progress → Confirmed
milestone: 15.10.0 → none
Aaron Wells (u-aaronw) on 2016-01-27
Changed in mahara:
status: Confirmed → In Progress
milestone: none → 16.04.0
tags: added: nominatedfeature
Aaron Wells (u-aaronw) wrote :

With this patch, wall posts now generate notifications. Specifically:

1. There is a new notification type called "Wall post", which defaults to "Email".
2. When a user makes a post on another user's wall, it generates a "Wall post" notification to the wall owner, containing the body of the message and a link to the user's wall page.
3. This notification is generated both for public wall posts and private wall posts.
4. No notification is generated when a user posts on their own wall.
5. The "Wall post" notification type has been added to the default "Inbox" block on the default user profile page template.
6. Existing user profile pages that still have an unmodified copy of the default "Inbox" block, have been updated to also include the "Wall post" notification type.

One noteable limitation, is that *only* the wall owner receives notifications. So, if a wall owner replies to a second user's comment on the owner's wall, the second user does NOT receive a notification. This will make it difficult to hold a conversation on a wall post, and I expect it's a feature that will soon be requested since that's how comment notifications now work.

However, it'll be tricky to implement non-wall-owner notifications. With comment notifications we worked around it by using the existing page watchlist to "Subscribe" commenters so they receive further notifications. Profile pages cannot be added to the watchlist, however. I suppose we could just change this so that profile pages *can* be watched. Either that, or implement some kind of notification subscription mechanism, and start using that with wall posts.

Aaron Wells (u-aaronw) wrote :

Thanks to SWITCH for funding the development of this patch.

Reviewed: https://reviews.mahara.org/5998
Committed: https://git.mahara.org/mahara/mahara/commit/3383d81665d0aaf1bf6353438fa67ca6dfdcbbbc
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 3383d81665d0aaf1bf6353438fa67ca6dfdcbbbc
Author: Aaron Wells <email address hidden>
Date: Thu Jan 14 20:18:29 2016 +1300

Notifications for new wall posts (Bug 547333)

Change-Id: Ib0de08d1ed51baa1f5e58ec1b805eacf034bb541

Robert Lyon (robertl-9) on 2016-02-04
Changed in mahara:
status: In Progress → Fix Committed
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers