umlauts crash configure-popup

Bug #488202 reported by Elhu on 2009-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Undecided
Richard Mansfield

Bug Description

serious problem with umlauts (ä, ä ...) in v1.2.
e.g. someone wrote umlauts in "my skills" and is trying to create a "new view"
with a block "one resume field" the configure-popup crash.

- i don't know if it's in 1.1 too.
- database is utf8
- php 5.2.6
- MySQL 5.0.41
- it doesn't matter if it's a fresh install or an upgrade

Changed in mahara:
milestone: none → 1.2.1
Changed in mahara:
assignee: nobody → Richard Mansfield (richard-mansfield)

I haven't reproduced the crash yet, but I have found and fixed a problem that caused the contents of the resume fields to fail to display on the configure popup when they contained entities such as ä

Elhu (e-huber) wrote :

Hello Richard,

if you could show me your fix, I would test it.
I use SeaMonkey and Firefox.
Btw, obviously this also affects a single blog post and chars like ß

best regards,
Elmar

Elhu (e-huber) wrote :

Hello Richard,

I tried the fix you posted, to "Problem adding blocks to views in IE7"
(http://gitorious.org/mahara/mahara/commit/464490363dedecd9d274cc13feefb19b1ee1cbd5)

Thanks, it works great!!!

Changed in mahara:
status: New → Fix Committed
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers