Turn text block into "Quick edit" block

Bug #1857931 reported by Kristina Hoeppner on 2019-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Cecilia Vela Gurovic

Bug Description

When learners work with templates that contain pre-defined text boxes, it will be beneficial when they don't have to enter edit mode to make their text additions. Instead, we are going to create a "Quick editing" functionality in the "Details" mode as a trial to see whether that functionality would be beneficial to the community.

The origin of the idea stems from templated portfolios where nurses need to provide a self assessment and peers provide a peer assessment. Peers can simply enter their text on the page whereas a nurse needs to go into edit mode and click the configure icon before they can make changes. That makes it impossible for them to see any instructions on the page once they are in the configuration modal and thus they need to go in and out of them editing text.

Instead of creating a new block type, the “Text” block type is revamped to support these new requirements and make it a versatile block to be used for other text purposes in the portfolio as well.

Characteristics of the block:
- The block can have instructions. When editing the block, the instructions are not immediately visible but hidden in a collapsible so that the content area is not too overwhelmed;
- Portfolio owner can add text directly on the page in details mode rather than needing to enter edit mode;
- When details mode is entered, portfolio owner sees the “Quick edit” option in the black bar that is shown at the top of a text block. They click “Quick edit” and the modal drawer is displayed from the right. A new function is created;
- The extra things, i.e. instructions, tags, and retractable option, go into an “Advanced” panel when configuring the block;
- In “Quick edit”, the instructions are displayed above the text box to be filled in like in the peer assessment block;
- Portfolio owner can save their content as draft first so it's only visible to them and then publish it once completed so others can view it. They can still make changes afterwards, but all these changes will be visible to others instantly while in draft mode, only they can see them. Once the content has been published, it cannot be set back to draft;
- It is still possible to edit text when opening the block in edit mode and clicking the “Configure block” icon, including draft and publish buttons.
- Things not taken over from the peer assessment block:
  -- Notifications about assessment;
  -- Profile picture and date stamp of assessment as it's the portfolio author's own page.

Note: Entering “Quick edit” via the details mode is chosen because one of the aims of Mahara 19.10 was to remove clutter from pages when they are viewed. That includes removing “Add comment” / “Details” links below artefacts that can have comments or have additional metadata. That information is still accessible via the details mode. When that mode is turned on, it is expected that work is to be done, e.g. commenting and reviewing comments.

Adding the “Quick” edit into the details bar is an extension of that and a way towards making editing of blocks faster than in the past as the details mode can stay turned on even when a page is refreshed and a viewer or portfolio author navigates to another page.

Changed in mahara:
assignee: nobody → Cecilia Vela Gurovic (ceciliavg)
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/10732
Committed: https://git.mahara.org/mahara/mahara/commit/86a57a9ffb8e6845fb0f5cafe092a12285ea20c7
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 86a57a9ffb8e6845fb0f5cafe092a12285ea20c7
Author: Cecilia Vela Gurovic <email address hidden>
Date: Thu Jan 9 17:06:16 2020 +1300

Bug 1857931: Add "Quick edit" and instructions to "Text" block

- add instructions field in text block
- Instructions are displayed in collapsible section on edit modal
- show 'quick edit' link in block header (page view mode)
only for user that can edit page
- display modal to configure block when clicking 'quick edit' header link
- saving text as draft, show text content only if
it's not draft or I'm a user that can edit the page
- don't display text block content if the text block is in draft
for other users that can access the page
- adding yellow background for blocks with draft status
- adding acessibility 'Draft' labels to blocks for screeen reader
- display expanded instructions in config modal if they are already set
- also display the instructions insode the block content, just above the text.
they are displayed in both display and edit page modes. The instructions are
always collapsed when the page is loaded

behatnotneeded
Change-Id: Ia1fa5c1beedab333728d1537d142c04adfd3c981

Robert Lyon (robertl-9) on 2020-06-15
Changed in mahara:
status: In Progress → Fix Committed
milestone: none → 20.10.0
tags: added: newfeature
Robert Lyon (robertl-9) on 2020-10-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers