Respect line breaks in account registration approval message

Bug #1823513 reported by Kristina Hoeppner on 2019-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Lisa Seeto

Bug Description

In bug #1440617 we added the possibility to send a message along with the account approval. That message does not respect line and paragraph breaks though running all paragraphs on each other putting them all into one paragraph.

That is not ideal because it makes a message less readable.

To replicate:

1. Allow self-registration on the site and force "Confirm registration" of new accounts in the institution settings.
2. Register for a new account.
3. As site admin, go to Admin menu -> Institutions -> "Pending registrations" for the institution in which the registration took place.
4. Click the "Approve" button next to the person you want to approve.
5. Fill in a reason on the next page that has some line breaks and paragraph breaks.
6. View the email that the user receives.

Expected result: The breaks show up properly making it an email that can be read easily.
Actual result: There are no line and paragraph breaks.

We don't have that problem in the denial messages.

While fixing this, can you please move the registration link message above the approval message so it's seen more easily when a long approval message follows? It is the text that looks like this:

Please follow this link to complete the sign-up process:

https://URL/register.php?key=wtTIqeH2RkyQJZnB

The link will expire in 24 hours.

Lisa Seeto (lisaseeto) on 2019-04-07
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Lisa Seeto (lisaseeto)

Reviewed: https://reviews.mahara.org/9720
Committed: https://git.mahara.org/mahara/mahara/commit/928081e8d0ca631d604411ea895c34029bdb01a0
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 928081e8d0ca631d604411ea895c34029bdb01a0
Author: Lisa Seeto <email address hidden>
Date: Mon Apr 8 10:38:28 2019 +1200

Bug 1823513: Respect line breaks in account registration approval message

Reorder lines in email message, use nl2br func to format message strings

behatnotneeded

Change-Id: Ib0c741b1199927d157e9b886bd4cc5c9d7dc77a7
Signed-off-by: Lisa Seeto <email address hidden>

Reviewed: https://reviews.mahara.org/9756
Committed: https://git.mahara.org/mahara/mahara/commit/6ef7d471525720778fa9cc10f56a87be14642a2f
Submitter: Robert Lyon (<email address hidden>)
Branch: 19.04_STABLE

commit 6ef7d471525720778fa9cc10f56a87be14642a2f
Author: Lisa Seeto <email address hidden>
Date: Mon Apr 8 10:38:28 2019 +1200

Bug 1823513: Respect line breaks in account registration approval message

Reorder lines in email message, use nl2br func to format message strings

behatnotneeded

Change-Id: Ib0c741b1199927d157e9b886bd4cc5c9d7dc77a7
Signed-off-by: Lisa Seeto <email address hidden>
(cherry picked from commit 928081e8d0ca631d604411ea895c34029bdb01a0)

Robert Lyon (robertl-9) on 2019-04-12
Changed in mahara:
status: In Progress → Fix Committed
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers