Institution report pages graph not showing

Bug #1821107 reported by Robert Lyon on 2019-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

When we updated the Chart.js plugin we made some adjustments to the displaying of the site pages graph
https://reviews.mahara.org/#/c/9436/12/htdocs/lib/statistics.php

- but forgot to update the institution one

Robert Lyon (robertl-9) on 2019-03-21
Changed in mahara:
status: New → In Progress
importance: Undecided → High
milestone: none → 19.04.0
tags: added: regression
Steven (stevens-q) wrote :

Testing 2 bugs - 1820927 & 1821107 code for both merged here https://reviews.mahara.org/#/c/9647

I have run 2 scenarios - one as site admin which appears to be working and one as Inst admin which I am not seeing a graph - I am not sure if this is expected.

////////////////////////////////////////////////////////////////////////////

Environment tested: Master
Browser tested: Chrome
-----------------------------------------------------------------------------

**Scenario 1** -Site admin creates group and enables 'participation report'

PRECONDITIONS:
------------------------
1) Site admin exists
2) Site admin creates a "Site Participate Group" and 'participation report' is enabled
3) Reports page (admin -> reports) = Report configuration = All institutions and Report type is set to Overview

TEST STEPS:
------------------------ 1) Log in as Site admin
2) Browse to "Site Participate Group" report page
3) Verify that the page mentions 1 portfolio ✔ (note Lower case p)
4) Site admin Browse to admin -> reports page
5) Verify the 'Pages by type' graph has 'Portfolio' ✔ (note Upper case P)

Catalyst QA Approved ✔

**********************************************************************
**********************************************************************

**Scenario 2** -Inst admin creates group and enables 'participation report'

PRECONDITIONS:
------------------------
1) User1 exists and is an Institution One admin
2) Institution One exists
3) Institution One admin creates "Participate Group" and 'participation report' is enabled
4) "Participate Group" exists and has the following members
   a) User1 - admin - has not added group page
   b) User3 - member - has added group page also has created a portfolio page
   c) User4 - member - has not added group page
5) Reports page (admin -> reports) = Report configuration = Institution One and Report type is set to Overview

TEST STEPS:
------------------------
1) Log in as User1
2) Browse to "Participate Group" report page
3) Verify that the page mentions 1 portfolio ✔ (note Lower case p)
4) User1 Browse to admin -> reports page
5) Verify the 'Pages by type' graph has 'Portfolio' ✘ -> (no graph or Portfolio text displayed)

Expected Result: As an Institution admin viewing the report found in the admin menu, I expected to see data in the Pages overview block on the report when the report is configured to display Inst One and report type = overview

Robert Lyon (robertl-9) wrote :

For the failing test you would need to do the following:
1) Log in as User1
2) Create a portfolio page
3) Force the cron to run the daily stats by running this command in database:
 UPDATE cron SET nextrun = NULL;
4) In a terminal run:
 sudo -u www-data php htdocs/lib/cron.php

5) Browse to "Participate Group" report page
6) Verify that the page mentions 1 portfolio
7) User1 Browse to admin -> reports page
8) Verify the 'Pages by type' graph has 'Portfolio'

Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)

Graph is visible as a site admin for all institution

Graph is visible as an institution admin for all institution

Reviewed: https://reviews.mahara.org/9647
Committed: https://git.mahara.org/mahara/mahara/commit/83c1aaa5e3f090e02196b03a2b01485b63b49206
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 83c1aaa5e3f090e02196b03a2b01485b63b49206
Author: Robert Lyon <email address hidden>
Date: Thu Mar 21 13:01:14 2019 +1300

Bug 1821107: Getting institution pages report graph to render

This one was not fixed when the site ones were fixed in
https://reviews.mahara.org/#/c/9436/12/htdocs/lib/statistics.php

behatnotneeded

Change-Id: I290d24b0d5abdddca132ec331a38bf0d2176a0ee
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2019-03-28
Changed in mahara:
status: In Progress → Fix Committed
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers