broken js in "general settings" from site options

Bug #1775103 reported by Cecilia Vela Gurovic on 2018-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Cecilia Vela Gurovic

Bug Description

In Admin menu -> Configure site -> Site options-> General settings, the first time we load the page clicking on the "Allow public pages" switch doesn't update "Allow public profiles" switch.

To test

Go to site options
Reload the page
go to general settings and click on "Allow public pages" switch

it should update "Allow public profiles" switch but it doesn't.

Save the form and try again without reloading the page.
Now it works properly, clicking on "Allow public pages" updates "Allow public profiles" switch.

Changed in mahara:
status: New → Confirmed
importance: Undecided → High

This sounds like a conflict with JS and Ajax. Robert's idea is to make this entire page work with JS only and not have Ajax calls and force a reload of the page when the "Save" button is clicked.

The switches that depend on each other would need to be tested in particular, e.g. the one mentioned in this report as well as the "Strict privacy" one.

no longer affects: mahara/17.04
no longer affects: mahara/17.10
no longer affects: mahara/18.04
Changed in mahara:
milestone: 18.10.0 → 19.04.0

I requested that you unsubscribe me please. My school has given me the
website to open an e portfolio. I don’t need this website any more. Thank
you

On Thu, 30 Aug 2018 at 03:15, Kristina Hoeppner <email address hidden>
wrote:

> This sounds like a conflict with JS and Ajax. Robert's idea is to make
> this entire page work with JS only and not have Ajax calls and force a
> reload of the page when the "Save" button is clicked.
>
> The switches that depend on each other would need to be tested in
> particular, e.g. the one mentioned in this report as well as the "Strict
> privacy" one.
>
> ** No longer affects: mahara/17.04
>
> ** No longer affects: mahara/17.10
>
> ** No longer affects: mahara/18.04
>
> ** Changed in: mahara
> Milestone: 18.10.0 => 19.04.0
>
> --
> You received this bug notification because you are subscribed to Mahara
> 18.04.3.
> https://bugs.launchpad.net/bugs/1775103
>
> Title:
> broken js in "general settings" from site options
>
> Status in Mahara:
> Confirmed
>
> Bug description:
> In Admin menu -> Configure site -> Site options-> General settings,
> the first time we load the page clicking on the "Allow public pages"
> switch doesn't update "Allow public profiles" switch.
>
> To test
>
> Go to site options
> Reload the page
> go to general settings and click on "Allow public pages" switch
>
> it should update "Allow public profiles" switch but it doesn't.
>
> Save the form and try again without reloading the page.
> Now it works properly, clicking on "Allow public pages" updates "Allow
> public profiles" switch.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1775103/+subscriptions
>

Hi Michael. I had sent you an email through Launchpad back in July in regard to this. See also https://bugs.launchpad.net/mahara/+bug/1775479/comments/2

I can't see you as subscriber here on the bugs and neither see that you are a member of a group and thus would receive Launchpad emails through your group membership. Please check your Launchpad settings and unsubscribe yourself.

Thanks
Kristina

Changed in mahara:
assignee: nobody → Cecilia Vela Gurovic (ceciliavg)
Changed in mahara:
status: Confirmed → In Progress
Steven (stevens-q) wrote :

Environment tested: Master
Browser tested: Chrome

PRECONDITIONS:
------------------------
1) Allow public pages is set to 'No'
2) Allow public profiles is set to 'No'

TEST STEPS:
------------------------
1) log in as Site admin
2) Browse to General settings page - Admin menu > Configure site > Site options > General settings
3) Toggle the 'Allow public pages' switch to 'Yes'
4) Confirm the 'Allow public profiles' switch is automatically switched to 'Yes' and is disabled ✔
5) Switch the 'Allow public pages' switch to 'No'
6) Verify that the 'Allow public profiles' switch is now enabled and can be set to either 'Yes' or 'No' ✔

Catalyst QA Approved ✔

Reviewed: https://reviews.mahara.org/9569
Committed: https://git.mahara.org/mahara/mahara/commit/ade25aa020d7aef117e3a787c8a93f4a3447b78d
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ade25aa020d7aef117e3a787c8a93f4a3447b78d
Author: Cecilia Vela Gurovic <email address hidden>
Date: Fri Feb 15 14:08:03 2019 +1300

Bug 1775103: "Allow public pages" switch updates "Allow public profiles" in Site options

(to fix these 2 switches until we imrpove the whole page)

behatnotneeded

Change-Id: I7491aeacce2b0fafb4173f9ac14c4ff85d6b4c98

Robert Lyon (robertl-9) on 2019-03-12
Changed in mahara:
status: In Progress → Fix Committed
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers