User export has column "remotename" instead of "remoteuser"

Bug #1773609 reported by Kristina Hoeppner on 2018-05-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Lisa Seeto

Bug Description

When you export user details via the "Reports" in Mahara, the column for the remote username / Username for external authentication is called "remotename". However, if you want to use the resulting CSV file to update user details, you'll have to rename that column to "remoteuser" first. It would be better if the column was called "remoteuser" to start with in the export.

To replicate:

1. Have a couple of users on your Mahara site.
2. Go to Admin -> User search and click the check boxes.
3. Click the "Get reports for selected users" button.
4. Download the data on the next screen.

Expected result: The column storing the remote username is called "remoteuser".
Actual result: It's called "remotename".

Robert Lyon (robertl-9) on 2018-05-27
Changed in mahara:
milestone: none → 18.10.0
status: Confirmed → In Progress
Steven (stevens-q) wrote :

The patch for the above bug differs from the expected result.
Both remoteuser and remotename are both valid column headers and can be used. This is because the system uses both and we do not want to get rid of one. ✔

The Intention of the bug is that a user can download a report for selected users in CSV format and then use the file to update users details/ re add them
(there is an "Update users" toggle button at the bottom of Add users by CSV page)

The following issues of the downloaded CSV file are
1. There is a column header (displayname) that must be removed
2. There is a column header (lastlogin) that must be removed
3. There is a column header (password) that must be added if you want to add users that may have been deleted

Catalyst QA failed testing as the overall intention was not met. ✘

We abandonded the original patch because it added complexity. Just make the CSV file download have the correct artefacttype names for preferredname and remoteuser.

Changed in mahara:
milestone: 18.10.0 → 19.04.0
status: In Progress → Confirmed
Lisa Seeto (lisaseeto) on 2019-03-07
Changed in mahara:
assignee: nobody → Lisa Seeto (lisaseeto)
Changed in mahara:
status: Confirmed → In Progress
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/9618

Lisa Seeto (lisaseeto) wrote :

The Intention of the bug is that a user can download a report for selected users in CSV format and then use the file to update users details/ re add them.
There is a column header (password) that must be added if you want to add users that may have been deleted.
Columns (quotapercent_format) and (lastlogin).

I'm not sure if it's likely that a Mahara user will try to upload a csv file containing members of mixed institutions but doing so will fail because the "institution" drop-down selection on "Add users by csv" page only allows for one institution to be selected at the time.

Steven (stevens-q) wrote :

Environment tested: Master
Browser tested: Chrome

PRECONDITIONS:
------------------------
1) Site admin user exists
2) The following users exist
      a) User1 - Institution One member
      b) User2 - Institution One member
      c) User3 - Institution One admin

TEST STEPS:
------------------------
1) Log in as Site admin
2) Browse to Admin menu -> User search and click the check boxes to left of the above users.
3) Click the "Get reports for selected users" button
4) Click the download link on the next screen (lower right of list)
5) Save the CSV file locally
6) Open the CSV file
7) Confirm the column storing the remote username is called "remoteuser" ✔

Catalyst QA Approved ✔

Reviewed: https://reviews.mahara.org/9618
Committed: https://git.mahara.org/mahara/mahara/commit/801fa661bb63a015a89230f4149113c4be2d0b80
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 801fa661bb63a015a89230f4149113c4be2d0b80
Author: Lisa Seeto <email address hidden>
Date: Tue Mar 12 11:08:30 2019 +1300

Bug 1773609: User export has column "remotename" instead of "remoteuser"

func generate_csv() altered to substitute preferredname and remoteuser
in /lib/mahara.php

behatnotneeded

Change-Id: I086caedf30acd51afed122996281a73762ddb107
Signed-off-by: Lisa Seeto <email address hidden>

Robert Lyon (robertl-9) on 2019-03-25
Changed in mahara:
status: In Progress → Fix Committed
tags: added: usermanualupdate
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers