delete icon not needed for primary email address

Bug #1756182 reported by Steven on 2018-03-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Lisa Seeto

Bug Description

Environment tested: Master
Browser tested: Chrome

===================
Manual Test Script
===================

1) user browse to Main menu > Profile > Contact information
2) User adds multiple email addresses
3) User tries to delete primary email address

Actual Result: error message is displayed "You cannot remove your primary email address."

Expected Result: If user cannot delete a primary email address, then the delete icon next to the primary email should not be displayed.

This is a bit more complicated: When a user changes the radio button to one of the other email addresses, they can delete the primary email address.

Scenarios:

1. Only one email address: There should not be a delete button as the only email address cannot be deleted.

2. One or more email addresses: The primary email does not have delete button. When the primary address is changed, it should receive the delete button and the now primary email address gets it removed.

Changed in mahara:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 18.10.0
Changed in mahara:
milestone: 18.10.0 → none
tags: added: snack-sized
Lisa Seeto (lisaseeto) on 2019-03-26
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Lisa Seeto (lisaseeto)
Lisa Seeto (lisaseeto) wrote :

Changes have been made to reflect some discussion:
a/ If the email is the primary email (will be radio button checked) do NOT have the delete icon.

b/ If a new email is added but not yet validated (user has not clicked the link sent in the validation email), it will display the email address with a disabled radio button, a validation message, and a delete icon.

c/ If another email address is added and has been validated (via clicking the link sent in the validation email) but NOT primary, it will display with a radio button that is enabled and a delete icon

NB: All changes, updates etc... must be "saved" via the "save profile" button on bottom of page to see any changes take place.

Robert Lyon (robertl-9) wrote :

There seems to be the following problems

1) Delete button alignment with verified and non verified email addresses
2) The non-verified button is bigger / icon not in center of button

See attached image

Reviewed: https://reviews.mahara.org/9669
Committed: https://git.mahara.org/mahara/mahara/commit/c69b66599afc11c8d3d4f8ad85f6c5992f991982
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit c69b66599afc11c8d3d4f8ad85f6c5992f991982
Author: Lisa Seeto <email address hidden>
Date: Wed Mar 27 13:14:10 2019 +1300

Bug 1756182: delete icon not needed for primary email address

delete button for email will not be created if it is the primary email address
updated css, tpl files to reflect new design changes

behatnotneeded

Change-Id: I48d44293d5c6519a7eaaa275dda902126029054e
Signed-off-by: Lisa Seeto <email address hidden>

Robert Lyon (robertl-9) on 2019-03-29
Changed in mahara:
status: In Progress → Fix Committed
milestone: none → 19.04.0
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers