Remove persona plugin: we need to remove lang directories inside auth/browserid folder

Bug #1745886 reported by Cecilia Vela Gurovic on 2018-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Rebecca Blundell

Bug Description

for bug
https://bugs.launchpad.net/mahara/+bug/1716811

we still need to remove extra lang directories inside auth/browserid.

If the Mahara instance being upgraded to 17.10 has other languages then auth/browserid directory will not be removed and we will see error:
(lib/upgrade.php:167) Plugin auth browserid is not installable: Plugin auth browserid is missing version.php

Changed in mahara:
importance: Undecided → Medium
status: New → Confirmed
Changed in mahara:
assignee: nobody → Rebecca Blundell (rjb-dev)
Rebecca Blundell (rjb-dev) wrote :

The problem is that if people have installed languages other than English the browserid directory is not removed from their instance of mahara when it is upgraded. They are left with an auth/browserid/lang folder containing the lang file for that plugin, which causes a warning message that the plugin cannot be installed.

We cannot programmatically remove the folder, but we can update the warning message to provide better information on the fix, which is to manually remove the plugin folder.

Reviewed: https://reviews.mahara.org/8519
Committed: https://git.mahara.org/mahara/mahara/commit/d89c2041f1478589fdf33a009402fefa3327b9b6
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit d89c2041f1478589fdf33a009402fefa3327b9b6
Author: Rebecca Blundell <email address hidden>
Date: Tue Feb 13 11:11:30 2018 +1300

Bug 1745886: Deprecated plugin shows better error message

-made error message that displays for a partial plugin easier to follow
-replaced hard-coded string message with string variable
-replaced hard-coded string with the variable in the other 2 places it
occurred

note: I also found an almost duplicated function that contained the
string.

behatnotneeded

Change-Id: Ifda3bb2155e2adeb775aef8c72b4a90b7d202f17

Robert Lyon (robertl-9) on 2018-02-16
Changed in mahara:
status: Confirmed → Fix Committed
milestone: none → 18.04.0
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers