Admin report on privacy

Bug #1734188 reported by Kristina Hoeppner on 2017-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Maria Sorica

Bug Description

We need to make a series of changes in Mahara to comply with the GDPR. More info is available on the wiki at https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/GDPR_compliance

We should have an admin report in the reports section in which admins can review the consented to items and the versions that users consented to.

This user report would consist of the following (items marked with * are mandatory and those marked with + are auto-selected):

- Username *
- First name *
- Last name *
- Display name
- Email
- Date and time when the privacy statement was accepted and consent was given (since it's all or nothing, I don't think we need separate dates for site and institution and consents but would need to link to each)
- Link to the agreed an consented items.

Instead of linking to each individual section, it would be nice if the privacy statement and all consent items were displayed on one page for each person via the report. That way multiple clicks could be avoided. We'd need such a page for the users already.

The page should mention the date of the privacy statement and consent items when they were published.

description: updated
Changed in mahara:
assignee: nobody → Maria Sorica (maria-sorica)
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/8527
Committed: https://git.mahara.org/mahara/mahara/commit/a0e5430d2795eca14739384fab86c88f6707b778
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit a0e5430d2795eca14739384fab86c88f6707b778
Author: Maria Sorica <email address hidden>
Date: Fri Feb 16 09:14:09 2018 +0000

Bug 1734188: User agreements report

behatnotneeded

Change-Id: Idb2a48f6e7c9b0c97f4c3b8fd19207964d96442e

Robert Lyon (robertl-9) on 2018-02-20
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers