Remove mention of username and email once account is deleted

Bug #1734186 reported by Kristina Hoeppner on 2017-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Cecilia Vela Gurovic

Bug Description

We need to make a series of changes in Mahara to comply with the GDPR. More info is available on the wiki at https://wiki.mahara.org/wiki/Developer_Area/Specifications_in_Development/GDPR_compliance

While we append a "deleted" at the end of a username and email address, it is still possible for someone looking into the database to identify the email address. Since we don't need to keep it, both username and email address should become a random value.

Changed in mahara:
assignee: nobody → Cecilia Vela Gurovic (ceciliavg)
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/8372
Committed: https://git.mahara.org/mahara/mahara/commit/31a5ceb2909a758dce202041cd662a3c39422723
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 31a5ceb2909a758dce202041cd662a3c39422723
Author: Cecilia Vela Gurovic <email address hidden>
Date: Wed Dec 20 10:15:14 2017 +1300

Bug 1734186: remove the username and email when deleting user

behatnotneeded

Change-Id: I0037ead6646e002c5cf96b43343f9aefc1a71754

Robert Lyon (robertl-9) on 2018-01-09
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers