SmartEvidence matrix headers jump when collapsed

Bug #1724968 reported by Kristina Hoeppner on 2017-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Unassigned

Bug Description

When you have pages in a SmartEvicende collection (any framework will do) and collapse the headers, the pages jump to the left. That should not happen and they should stay put.

See the attached screenshot to illustrate the issue.

How to replicate:

1. Create 5 pages.
2. Create a SmartEvidence collection and choose any framework adding the 5 pages to the collection.
3. View the SmartEvidence matrix page and collapse the / one of the headers (depending on the framework you selected)

Expected result: Page title stay where they were in uncollapsed state.
Actual result: The page titles jump to the left and then back when you uncollapse the standard header.

Changed in mahara:
status: Confirmed → In Progress
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/8290

Reviewed: https://reviews.mahara.org/8290
Committed: https://git.mahara.org/mahara/mahara/commit/e46ef96987ecc0677451ad73a6d927931dc0e1c5
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit e46ef96987ecc0677451ad73a6d927931dc0e1c5
Author: Robert Lyon <email address hidden>
Date: Fri Oct 27 19:41:39 2017 +1300

Bug 1724968: Fix for jumping page titles in SmartEvidence using js

Because there matrix table has a number of complicated things going on
it might not be able to solve this problem with css alone

So I've created a js fix for the problem

behatnotneeded

Change-Id: I10b270885eb2e8fc87ed19f5fbb9819ef466ddb8
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2018-01-15
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers