Remove "Mobile access token" from account settings

Bug #1660237 reported by Kristina Hoeppner on 2017-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Cecilia Vela Gurovic

Bug Description

With Mahara 16.10 we introduced Mahara Mobile, the new mobile app for Mahara and with it the "App" settings that are managed on /module/mobileapi/apps.php

We still show the "Mobile access tokens" on /account/index.php though and on /admin/site/options.php when a site has been upgraded to 16.10. These settings should be removed as they are confusing. Both MaharaDroid and Portfolio Up are not in active development and do not necessarily work with modern devices. Mahara Mobile allows any user to connect, not just with internal accounts.

Changed in mahara:
milestone: 17.04.0 → 17.10.0
Robert Lyon (robertl-9) wrote :

Actually we should remove the code that dealt with the old mobile upload file way and leave the files the apps hit to return a JSON message about installing Mahara mobile app instead

Changed in mahara:
milestone: 17.10.0 → 18.04.0
importance: Medium → High
status: Triaged → Confirmed
Changed in mahara:
assignee: nobody → Cecilia Vela Gurovic (ceciliavg)
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/8085
Committed: https://git.mahara.org/mahara/mahara/commit/d7018426d0538211ecd4a2327ea659c47535989f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit d7018426d0538211ecd4a2327ea659c47535989f
Author: Cecilia Vela Gurovic <email address hidden>
Date: Tue Oct 3 15:38:53 2017 +1300

Bug 1660237: removed old mobile api

removed code from htdocs/api/module/ files and replace it with a json reply error message.
removed the 'allowmobileuploads' config variable since it is only used by the old mobile api.
removed the 'mobileuploadtoken' values in usr_account_preferences since they are only used by old mobile api. The new mahara mobile uses external_tokens table to store its access tokens.

behatnotneeded

Change-Id: I02e94079fc83aa6a81534b70446f7e8ab2ebd7a4

Robert Lyon (robertl-9) on 2017-10-30
Changed in mahara:
status: In Progress → Fix Committed
tags: added: usermanualupdate

Reviewed: https://reviews.mahara.org/8255
Committed: https://git.mahara.org/mahara/mahara/commit/56ae7d7a4d4103963f754c5c2f7981c40dc3152e
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 56ae7d7a4d4103963f754c5c2f7981c40dc3152e
Author: Robert Lyon <email address hidden>
Date: Mon Nov 6 10:58:25 2017 +1300

Bug 1660237: Adding log debug message when upgrading

As per convention when adding an upgrade block

behatnotneeded

Change-Id: Ifb33f6e588093d800ea983347ba888a9c5ed18d2
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers