Search box in configurable theme needs better outline

Bug #1660101 reported by Kristina Hoeppner on 2017-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Liam

Bug Description

When using the configurable theme, the search box looks a bit odd when the search buttons have an outline as the outline is only for 3 sides but not all 4 (see screenshot).

I can see two options:

1. Extend the button outline to the search box itself.
2. Ensure that the 4th side of the button has the outline.

tags: added: front-end
Liam (liam-sharpe) wrote :

I opted to add both a border to the left side of the button and around the input block as I thought this looked the best from the available options.

Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Liam (liam-sharpe)
Niranjan (niranjan528) wrote :
Liam (liam-sharpe) wrote :

Hi Niranjan

It works fine on my computer but I have realised one thing:

You need to disable the institution theme (in the institution settings) and set it to another theme e.g. raw, then click save. And then set it as config theme and save again.

Only after doing this are the changes applied as the CSS is generated and stored on the database so it ignores any code changes until the config theme is re-applied.

Thanks,
Liam

You don't even need to change to another theme. Just a click on "Save" is sufficient. :-) That's normal behavior for that theme right now as the values are stored in the DB until changed via "Save". So this is acceptable and not a bug of your patch, Liam.

Reviewed: https://reviews.mahara.org/7425
Committed: https://git.mahara.org/mahara/mahara/commit/6885374cfd554e3521bba292d997a5ef239fe652
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 6885374cfd554e3521bba292d997a5ef239fe652
Author: Liam <email address hidden>
Date: Mon Jan 30 11:09:25 2017 +1300

Bug #1660101: Extend outline to entire search box in configurable theme

behatnotneeded

Change-Id: I027963832c4b245f3e27c224f13942cf4f25e972

Robert Lyon (robertl-9) on 2017-03-01
Changed in mahara:
status: In Progress → Fix Committed
milestone: none → 17.04.0
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers