SmartEvidence not available when in multiple institutions

Bug #1656998 reported by Kristina Hoeppner on 2017-01-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Unassigned
16.10
Medium
Unassigned

Bug Description

When you are a member of multiple institutions and at least one of them does not have SmartEvidence selected, you won't be able to use it. Or more specifically, SmartEvidence use goes according to the setting of your "first" institution's setting if you are in multiple.

The use or not use of SmartEvidence should work like we have other multiple institution settings work: If you allow the use of SmartEvidence in one institution but not others, you can still use it all the time as you are in one institution that allows SmartEvidence. We allow for the more permissive use case as we do not create pages in a specific collection, but just in an account.

To replicate:

1. Set up institution "School" and don't allow SmartEvidence.
2. Set up institution "University" and allow SmartEvidence.
3. Add a user to both institutions.
4. Expected result: The user should be able to set up a SmartEvidence collection. Current result: The user can't because the first institution is "School" and that doesn't allow SmartEvidence.

Reviewed: https://reviews.mahara.org/7399
Committed: https://git.mahara.org/mahara/mahara/commit/31d2e73c4b67c7fbd30d4fdb349b4e05c203fc96
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 31d2e73c4b67c7fbd30d4fdb349b4e05c203fc96
Author: Robert Lyon <email address hidden>
Date: Tue Jan 17 12:44:35 2017 +1300

Bug 1656998: Allow SmartEvidence for user on multiple instituions

If any of their institutions allow it (not just the first one)

behatnotneeded

Change-Id: I5101e87c2d49c7d0ab8bbc091f5a34dcb1f73708
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2017-02-20
Changed in mahara:
status: Confirmed → Fix Committed

Reviewed: https://reviews.mahara.org/7477
Committed: https://git.mahara.org/mahara/mahara/commit/e800a2c39d8045a17313d954d9f444267bdc40c8
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.10_STABLE

commit e800a2c39d8045a17313d954d9f444267bdc40c8
Author: Robert Lyon <email address hidden>
Date: Tue Jan 17 12:44:35 2017 +1300

Bug 1656998: Allow SmartEvidence for user on multiple instituions

If any of their institutions allow it (not just the first one)

behatnotneeded

Change-Id: I5101e87c2d49c7d0ab8bbc091f5a34dcb1f73708
Signed-off-by: Robert Lyon <email address hidden>
(cherry picked from commit 31d2e73c4b67c7fbd30d4fdb349b4e05c203fc96)

Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers