PluginAuthSaml error after upgrade

Bug #1653030 reported by Kristina Hoeppner on 2016-12-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Cecilia Vela Gurovic
16.10
High
Unassigned
17.04
High
Cecilia Vela Gurovic

Bug Description

When I upgrade 15.10, 16.04 or 16.10 to 17.04dev I get the following warning:

[WAR] f9 (lib/errors.php:536) [Error]: Class 'PluginAuthSaml' not found
Call stack (most recent first):

    exception(object(Error)) at Unknown:0

That's just on a plain fresh database.

Changed in mahara:
assignee: nobody → Cecilia Vela Gurovic (ceciliavg)
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/7376
Committed: https://git.mahara.org/mahara/mahara/commit/ccabcdac4fc1a3a175a6f9d3435aa571b213cf77
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ccabcdac4fc1a3a175a6f9d3435aa571b213cf77
Author: Cecilia Vela Gurovic <email address hidden>
Date: Wed Jan 4 16:42:15 2017 +1300

Bug 1653030: fix for PluginAuthSaml error when upgrading

Required lib file so PluginAuthSaml class
is available when it is called

behatnotneeded

Change-Id: I2b9a74e8a49c14b449d021212af7595302e0a517

Robert Lyon (robertl-9) on 2017-01-08
Changed in mahara:
status: In Progress → Fix Committed

Reviewed: https://reviews.mahara.org/7449
Committed: https://git.mahara.org/mahara/mahara/commit/bc353c69b02e4f6543e974598191b24d8d91f68e
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit bc353c69b02e4f6543e974598191b24d8d91f68e
Author: Robert Lyon <email address hidden>
Date: Mon Feb 13 07:33:58 2017 +1300

Bug 1653030: Using safe require auth saml

To make sure all dependent classes are included as well

behatnotneeded

Change-Id: Ib93776b163193849938619cbe9bbb7e073df7a02
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/7450
Committed: https://git.mahara.org/mahara/mahara/commit/dac4903fe20e9d52a282ec14785b0f86346b7bc4
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.10_STABLE

commit dac4903fe20e9d52a282ec14785b0f86346b7bc4
Author: Robert Lyon <email address hidden>
Date: Mon Feb 13 07:33:58 2017 +1300

Bug 1653030: Using safe require auth saml

To make sure all dependent classes are included as well

behatnotneeded

Change-Id: Ib93776b163193849938619cbe9bbb7e073df7a02
Signed-off-by: Robert Lyon <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers