Top info messages should not be pushing content incorrectly

Bug #1651913 reported by Kristina Hoeppner on 2016-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Pat

Bug Description

When you have a fixed header for your Mahara site and it is wider than the default one, content below it should still be displayed correctly and not covered. Currently, when you have productionmode = false or masquerade as someone, the header is pushed down, but the flexible content area is not and thus not all content is shown.

There should be a general fix for that as not all themes require it, but if someone builds a custom theme using raw or another theme as basis, they shouldn't have to worry about it.

Changed in mahara:
assignee: nobody → Pat (pat-kira)
Pat (pat-kira) wrote :

Firstly, navigation position (or styles) relies on a class which is added by "siteMessages" function in theme.js. The function counts the number of site messages and adds message-count-{number} class on header element (.header) and main navigation (.main-nav). And this is true for "raw" and core themes.

However in Mahara.org 16.04 upgrade, there where some changes in the templates to make 16.04 look like how it was before as a result I had to changed selectors in mahara-org theme js to get the site message styles to behave correctly. When we updated to 16.10 (current theme), the template especially markups around navigation were changed, there were some consolidations around user navigation and the main navigation is on the page content rather than being below header. The issue you have mentioned above is rather specific to mahara.org theme (I have submitted a patch for that).

As for Mahara core, I can add a note in the documentation about how fixed header with site messages should be styled since there are 3 places (js, markup and css) to consider if one is changed.

Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/7423
Committed: https://git.mahara.org/mahara/mahara/commit/e30f848632e4f43d51dcdc83673a6b59270c95b2
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit e30f848632e4f43d51dcdc83673a6b59270c95b2
Author: Pat Kira <email address hidden>
Date: Fri Jan 27 14:49:45 2017 +1300

Bug 1651913 - Add theming instruction for fixed header and site messages

Any amendment in the header and main navigation markup may require
changes in theme.js and site messages styles.

behatnotneeded - Updated theme readme

Change-Id: I83fa7120ed9cc51de9fd43f22bfbe966a9dfcf0e

Robert Lyon (robertl-9) on 2017-03-13
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers