The file list overflow incorrectly with mobile devices

Bug #1648858 reported by Gilles-Philippe Leblanc on 2016-12-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Liam

Bug Description

To reproduce:
* Go to Content > Files
* Add a file with a long name (ex. super_long_file_name_that_breaks_the_layout.jpg)
Actual: With mobile devices, the table go outside the page layout
Expected: The table do not go outside the page layout but a scroll is added for that table

Changed in mahara:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 17.04.0
tags: added: front-end
Changed in mahara:
assignee: nobody → Liam (liam-sharpe)
Liam (liam-sharpe) on 2016-12-13
Changed in mahara:
status: Confirmed → In Progress

Hi, I have a fix for this bug but I just need some time to share it with you (at the end this week) Thank you!
I see you have already a fix for it but mines is a little different. Maybe we can compare to find the better solution. Thanks!

Gilles-Philippe, can you please take a look at the patch and see if that fixes your problem? The issue is not just mobile devices but also regular browsers when the file name is too long.

Happy to also take a look at your patch :-)

Reviewed: https://reviews.mahara.org/7328
Committed: https://git.mahara.org/mahara/mahara/commit/74137491ab02c1710981bd9c9a21ae29fb0f4eea
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 74137491ab02c1710981bd9c9a21ae29fb0f4eea
Author: Liam <email address hidden>
Date: Tue Dec 13 13:01:54 2016 +1300

Bug #1648858: Fixed table overflowing on small screens on files page

behatnotneeded

Change-Id: I00c8374f57070d96f75325b081ee399d577bd4c5

Robert Lyon (robertl-9) on 2016-12-20
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers