The bottom margin of the first file picker is different of the other filepickers

Bug #1648131 reported by Gilles-Philippe Leblanc on 2016-12-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Liam

Bug Description

To reproduce:
* Click on the menu: Content > Resume
* On the "Education history" section, click on the "Add" button
* Then, click on the "Add attachment" button 3 times

Expected: The margin between the first file picker may be equal of the margin between the others file pickers.

Changed in mahara:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Liam (liam-sharpe)
milestone: none → 17.04.0
tags: added: front-end
Liam (liam-sharpe) on 2016-12-12
Changed in mahara:
status: Confirmed → In Progress

This problem can be observed in "Employment history". We are changing that to the same icon though as under "Education history" to make it more consistent (in a different bug). The fix will still be good in case the same style is used elsehwere.

Interesting: When you add a new item (no matter whether ed history or employment history), you see the buttons as described here. However, when you edit an item, you see a different button. That's what had me confused. Bug report is at bug #1649433.

Hi! I have a fix for this bug but I just need some time to share it with you (at the end this week). Thank you !

Gilles-Philippe, please take a look at the fix that Liam provided and see if that works for you.

Reviewed: https://reviews.mahara.org/7327
Committed: https://git.mahara.org/mahara/mahara/commit/275843224f143bd4b2ada301cc9579ec04e8c96c
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 275843224f143bd4b2ada301cc9579ec04e8c96c
Author: Liam <email address hidden>
Date: Tue Dec 13 12:48:22 2016 +1300

Bug #1648131: Fixed no bottom margin on choose file button on emplyment page

behatnotneeded

Change-Id: If65e7d1f40e36afd252b249407d898116f9cc11a

Robert Lyon (robertl-9) on 2016-12-14
Changed in mahara:
status: In Progress → Fix Committed

The fix seems OK but it is not correct.
It add now two margin-bottom to each element but the first one.
Its not visible only because the two bottom margin overlap.
* Go to developer mode on your browser (F12) and go see the file picker.
* You will see that each picker picker but the first are surrounded by a div.file-wrapper.

Hopefully, the two bottom-margin is only applied one that why you don't see the problem but that why I don't think the actual fix is the best.

I just committed mines. It modify the html and the class to correctly use the file wrapper. This way, the first file-picker is wrapped in the <div class="file-wrapper"> like the other added after.

I putted two fix. One with my patch and the second with the remove of the first fix already merged.

Changed in mahara:
status: Fix Committed → In Progress
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/7362

Reviewed: https://reviews.mahara.org/7362
Committed: https://git.mahara.org/mahara/mahara/commit/5303211437fa1d675ff2876f8aed23f1fd93542d
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 5303211437fa1d675ff2876f8aed23f1fd93542d
Author: Gilles-Philippe Leblanc <email address hidden>
Date: Mon Dec 19 16:23:52 2016 -0500

Bug 1648131: fixed bottom margin of first file picker

behatnotneeded: style change only

Change-Id: Ib4f8816f2ce2d65aef8d4eab97da36f030cf35a4

Robert Lyon (robertl-9) on 2016-12-23
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers