Update NPM packages in package.json

Bug #1617143 reported by Son Nguyen on 2016-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Son Nguyen

Bug Description

Version: master (16.10)

We should update NPM packages to the latest version

 gulp ^3.9.0 → ^3.9.1
 gulp-minify-css ^1.1.6 → ^1.2.4 (Deprecated)
 gulp-sass ^2.0.1 → ^2.3.2
 event-stream ^3.3.1 → ^3.3.4
 gulp-autoprefixer ^3.0.1 → ^3.1.1
 es6-promise ^3.0.2 → ^3.2.1
 gulp-if ^2.0.0 → ^2.0.1
 globule ^0.2.0 → ^2.0.1 (the dependent package minimatch 0.2.14 need to update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue)

Replacing gulp-minify-css by gulp-clean-css is reported in 1569121

Son Nguyen (ngson2000) on 2016-08-26
Changed in mahara:
status: New → Confirmed
importance: Undecided → Medium
Son Nguyen (ngson2000) on 2016-08-28
description: updated
Son Nguyen (ngson2000) on 2016-08-28
Changed in mahara:
status: Confirmed → In Progress
importance: Medium → High
assignee: nobody → Son Nguyen (ngson2000)

Reviewed: https://reviews.mahara.org/6893
Committed: https://git.mahara.org/mahara/mahara/commit/d11cf25c85c7f0f72001c06e70176ec4dec16740
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit d11cf25c85c7f0f72001c06e70176ec4dec16740
Author: Son Nguyen <email address hidden>
Date: Mon Aug 29 08:20:37 2016 +1200

Bug 1617143: Update NPM packages in package.json

behatnotneeded

Change-Id: If8c5535d85e78eb53ab855bcc400477c9d795a8c

Robert Lyon (robertl-9) on 2016-09-01
Changed in mahara:
status: In Progress → Fix Committed
milestone: none → 16.10.0
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers