Accessibility - Inconsistent heading levels

Bug #1606735 reported by Ghada El-Zoghbi on 2016-07-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Pat

Bug Description

Mahara: master

Headings jump levels - i.e. h1 -> h3 skipping h2.

Heading levels should be used in sequence to assist users in understanding the structure of the page. And, prevent screen readers from skipping sections.

For additional information, please refer to: http://webaim.org/techniques/semanticstructure/#contentstructure

tags: added: accessibility
Changed in mahara:
milestone: none → 16.10.0
importance: Undecided → Medium
status: New → Confirmed
tags: added: front-end
Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Pat (pat-kira)

Reviewed: https://reviews.mahara.org/7307
Committed: https://git.mahara.org/mahara/mahara/commit/60c7eca54b1b00f720d53bd4cf23cd2544fc8056
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 60c7eca54b1b00f720d53bd4cf23cd2544fc8056
Author: Pat Kira <email address hidden>
Date: Fri Dec 9 15:01:43 2016 +1300

Bug 1606735 - Changed heading markup where possible for accessibility

This patch excludes:
- Admin section
- H4 in the pieform since it was added to improve accessibility
- User generated page/content

Note: There are still number of pages with heading being skipped heading
especially H2. Most of the pages have H1 and H3, H1 for page heading and
h3 for sidebar panel heading. We can look into marking up sideber panels
as sections with header etc.

behatnotneeded: markup and styles changes only

Change-Id: Ic592f5be63aa2e7fbd7e31928db7c230e425f104

Robert Lyon (robertl-9) on 2017-01-29
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers