Modern theme: disappearing password label

Bug #1579628 reported by Ghada El-Zoghbi on 2016-05-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Liam
15.10
High
Unassigned
16.04
High
Unassigned
16.10
High
Liam

Bug Description

Mahara: 16.04
os: Linux
DB: Postgres
Browser: FF, Chrome

When the theme is Modern and the user types in the wrong username / password credentials on the login screen, the label for the password appears as white on white. It looks like the label is no longer there.

Please refer to the attached image.

Ghada El-Zoghbi (ghada-z) wrote :

Ghada, are you going to fix this?

tags: added: front-end
removed: theming
Changed in mahara:
status: New → Confirmed
importance: Undecided → High
milestone: none → 16.10.0

While the text is now readable in the patch, the outline of the password box is not yet. A very light outline is there once you clicked into the field, but none when it's not clicked yet. This still needs fixing in the patch.

Reviewed: https://reviews.mahara.org/6544
Committed: https://git.mahara.org/mahara/mahara/commit/5709e5507dc0a2d9abffac3febe7075944cf6e48
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 5709e5507dc0a2d9abffac3febe7075944cf6e48
Author: Liam Sharpe <email address hidden>
Date: Fri Jun 3 09:51:01 2016 +1200

Bug #1579628: Fixed invisibible password label in theme "Modern"

When a wrong password was entered on the login scrren, the password label
could not be read because it was white on white in the "Modern" theme.

Is a generic issue with Modern theme forms

behatnotneeded

Change-Id: I37c29633b247b60c08760f7c90dc8937f629dd81

Mahara Bot (dev-mahara) wrote :

Patch for "15.10_STABLE" branch: https://reviews.mahara.org/6580

Reviewed: https://reviews.mahara.org/6580
Committed: https://git.mahara.org/mahara/mahara/commit/0fea03ade929ba38bb15649209d7ad726a25f8ac
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 0fea03ade929ba38bb15649209d7ad726a25f8ac
Author: Liam Sharpe <email address hidden>
Date: Fri Jun 3 09:51:01 2016 +1200

Bug #1579628: Fixed invisibible password label in theme "Modern"

When a wrong password was entered on the login scrren, the password label
could not be read because it was white on white in the "Modern" theme.

Is a generic issue with Modern theme forms

behatnotneeded

Change-Id: I37c29633b247b60c08760f7c90dc8937f629dd81
(cherry picked from commit 5709e5507dc0a2d9abffac3febe7075944cf6e48)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6579
Committed: https://git.mahara.org/mahara/mahara/commit/52da22d82685aa9742dfb73e9f8a98c16c503a15
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.04_STABLE

commit 52da22d82685aa9742dfb73e9f8a98c16c503a15
Author: Liam Sharpe <email address hidden>
Date: Fri Jun 3 09:51:01 2016 +1200

Bug #1579628: Fixed invisibible password label in theme "Modern"

When a wrong password was entered on the login scrren, the password label
could not be read because it was white on white in the "Modern" theme.

Is a generic issue with Modern theme forms

behatnotneeded

Change-Id: I37c29633b247b60c08760f7c90dc8937f629dd81
(cherry picked from commit 5709e5507dc0a2d9abffac3febe7075944cf6e48)

Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
status: Fix Committed → Fix Released
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.0 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers