comments with attachments - attachment titles and links display on main portfolio page

Bug #1554247 reported by Francine Glazer on 2016-03-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Unassigned
15.10
High
Unassigned
16.04
High
Unassigned
16.10
High
Unassigned

Bug Description

I'm running 15.10.1 and have the following problem:

We use the portfolios for a standard process that requires people to attach letters to note blocks on the page. When they do add the attachments, sometimes the attachment filenames (actually, links to the attachments) are visible on the main portfolio page, sometimes in a list and sometimes on top of one another. They "float" above the page, meaning that if I scroll the page up and down, the attachment filenames/links do not move up and down with the page. This display bug is reproducible on multiple browsers (Safari, Chrome).

I'd hoped that the 15.10.1 patch would resolve this issue, but it did not.

thanks,
Fran

Francine Glazer (fglazer) wrote :

Can you please let us know which browser you are using, Fran?

Changed in mahara:
status: New → Triaged
importance: Undecided → High
milestone: none → 16.04.0
tags: added: bootstrap

Hi Kristina,

I've seen this bug so far in both chrome and safari. Have not tried Firefox, and we ask people not to use Internet explorer.

Fran

Sent from my iPad

> On Mar 11, 2016, at 5:25 PM, Kristina Hoeppner <email address hidden> wrote:
>
> Can you please let us know which browser you are using, Fran?
>
> ** Changed in: mahara
> Status: New => Triaged
>
> ** Changed in: mahara
> Importance: Undecided => High
>
> ** Changed in: mahara
> Milestone: None => 16.04.0
>
> ** Also affects: mahara/15.10
> Importance: Undecided
> Status: New
>
> ** Changed in: mahara/15.10
> Status: New => Triaged
>
> ** Changed in: mahara/15.10
> Importance: Undecided => High
>
> ** Changed in: mahara/15.10
> Milestone: None => 15.10.2
>
> ** Tags added: bootstrap
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1554247
>
> Title:
> comments with attachments - attachment titles and links display on
> main portfolio page
>
> Status in Mahara:
> Triaged
> Status in Mahara 15.10 series:
> Triaged
>
> Bug description:
> I'm running 15.10.1 and have the following problem:
>
> We use the portfolios for a standard process that requires people to
> attach letters to note blocks on the page. When they do add the
> attachments, sometimes the attachment filenames (actually, links to
> the attachments) are visible on the main portfolio page, sometimes in
> a list and sometimes on top of one another. They "float" above the
> page, meaning that if I scroll the page up and down, the attachment
> filenames/links do not move up and down with the page. This display
> bug is reproducible on multiple browsers (Safari, Chrome).
>
> I'd hoped that the 15.10.1 patch would resolve this issue, but it did
> not.
>
> thanks,
> Fran
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1554247/+subscriptions

Thanks Fran. We'll look into it.

Robert Lyon (robertl-9) wrote :

Hi Fran,

Would it be possible to get access to that page or get the html source of that page to be able to see more of what is going on?

I am unable to replicate the error locally.

Are each of those 'Review and Recommendation' Note blocks on the page and are they rendered collapsed? If so, can you do a screenshot when they are expanded?

I am wondering if there is some text/html that has been added to the blocks that is breaking the part that is meant to display the attachment list causing it to display in the wrong place.

Cheers

Robert

Francine Glazer (fglazer) wrote :

Robert,

I'm attaching a zip file that includes the 3 screenshots plus the source code for each view.
- the page as it initially displays (shows attachment file name on top of page)
- the page with the comment box opened
- the page once the comment box has closed (the attachment file name has disappeared!)
when I refresh the page, the file names reappear.

You will see that all three source code files are identical (at least based on popping them into Kaleidoscope) so I'm not sure how much help that will be.

thank you!
Fran

Francine Glazer (fglazer) wrote :

here's all three screenshots so you don't have to unzip the archive

Francine Glazer (fglazer) wrote :

Robert,
was the source code helpful?

thanks,
Fran

Liam (liam-sharpe) wrote :

Hi Fran

Has upgrading to the latest version of Mahara fixed this issue?

I have been unable to replicate the bug so far.

Thank you,
Liam Sharpe

Hi Liam,

Unfortunately the issue is still with us. Would it help if I made a short screencast to show you what happens? Or to schedule a videoconference call?

Best,
Fran

Sent from my iPad

> On May 4, 2016, at 7:25 PM, Liam <email address hidden> wrote:
>
> Hi Fran
>
> Has upgrading to the latest version of Mahara fixed this issue?
>
> I have been unable to replicate the bug so far.
>
> Thank you,
> Liam Sharpe
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1554247
>
> Title:
> comments with attachments - attachment titles and links display on
> main portfolio page
>
> Status in Mahara:
> Triaged
> Status in Mahara 15.10 series:
> Triaged
> Status in Mahara 16.04 series:
> Triaged
> Status in Mahara 16.10 series:
> Triaged
>
> Bug description:
> I'm running 15.10.1 and have the following problem:
>
> We use the portfolios for a standard process that requires people to
> attach letters to note blocks on the page. When they do add the
> attachments, sometimes the attachment filenames (actually, links to
> the attachments) are visible on the main portfolio page, sometimes in
> a list and sometimes on top of one another. They "float" above the
> page, meaning that if I scroll the page up and down, the attachment
> filenames/links do not move up and down with the page. This display
> bug is reproducible on multiple browsers (Safari, Chrome).
>
> I'd hoped that the 15.10.1 patch would resolve this issue, but it did
> not.
>
> thanks,
> Fran
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1554247/+subscriptions

Liam (liam-sharpe) wrote :

Hi Fran

I think a screencast would be quite helpful thank you.

Thank you,
Liam Sharpe

Here you go, Liam!

http://screencast.com/t/PmiKjHswd

best,
Fran

> On May 5, 2016, at 5:38 PM, Liam <email address hidden> wrote:
>
> Hi Fran
>
>
> I think a screencast would be quite helpful thank you.
>
> Thank you,
> Liam Sharpe
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1554247
>
> Title:
> comments with attachments - attachment titles and links display on
> main portfolio page
>
> Status in Mahara:
> Triaged
> Status in Mahara 15.10 series:
> Triaged
> Status in Mahara 16.04 series:
> Triaged
> Status in Mahara 16.10 series:
> Triaged
>
> Bug description:
> I'm running 15.10.1 and have the following problem:
>
> We use the portfolios for a standard process that requires people to
> attach letters to note blocks on the page. When they do add the
> attachments, sometimes the attachment filenames (actually, links to
> the attachments) are visible on the main portfolio page, sometimes in
> a list and sometimes on top of one another. They "float" above the
> page, meaning that if I scroll the page up and down, the attachment
> filenames/links do not move up and down with the page. This display
> bug is reproducible on multiple browsers (Safari, Chrome).
>
> I'd hoped that the 15.10.1 patch would resolve this issue, but it did
> not.
>
> thanks,
> Fran
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1554247/+subscriptions

Ok. Fran and I figured it out.

1. Change your column layout to 1 column.
2. Add a note block to the page and allow comments.
3. Place a comment on the note block and add an attachment.
4. Go back and view the entire page.

Expected result: Attachment name is not displayed around the header of the site (see screencast).
Actual result: See screencast.

The error only seems to appear in the 1-column layout. It does not appear in the 3- or 2-column one.

Reviewed: https://reviews.mahara.org/6860
Committed: https://git.mahara.org/mahara/mahara/commit/76fe713b7624ae49d789d45a1b874e40fc18d56f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 76fe713b7624ae49d789d45a1b874e40fc18d56f
Author: Pat Kira <email address hidden>
Date: Thu Aug 18 14:19:24 2016 +1200

Bug 1554247 - Fixed attachment file links showing up on fullwidth layout

behatnotneeded

Change-Id: I00da7d2a319dacabc802c09f1a668f0f37db7057

Mahara Bot (dev-mahara) wrote :

Patch for "16.04_STABLE" branch: https://reviews.mahara.org/6861

Mahara Bot (dev-mahara) wrote :

Patch for "15.10_STABLE" branch: https://reviews.mahara.org/6862

LIsa (lisadunmire) wrote :

Tested in CHrome and Safar

Test steps:

Create a page>Enter description and Save
Page created is displayed>Edit layout and click on 1 column then Save
Drag Text block>enter content and Save
Click General>Note and enter content the Save
Display page>Add comment and attachment>click Comment
From Dashboard, click on the page
Page is displayed

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6861
Committed: https://git.mahara.org/mahara/mahara/commit/ad370b9dd4a748a7f9a37adfc86513872e3bf9d5
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.04_STABLE

commit ad370b9dd4a748a7f9a37adfc86513872e3bf9d5
Author: Pat Kira <email address hidden>
Date: Thu Aug 18 14:19:24 2016 +1200

Bug 1554247 - Fixed attachment file links showing up on fullwidth layout

behatnotneeded

Change-Id: I00da7d2a319dacabc802c09f1a668f0f37db7057
(cherry picked from commit 76fe713b7624ae49d789d45a1b874e40fc18d56f)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6862
Committed: https://git.mahara.org/mahara/mahara/commit/5a3257f495f9667abf7364cddd33b8d60cec9df9
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 5a3257f495f9667abf7364cddd33b8d60cec9df9
Author: Pat Kira <email address hidden>
Date: Thu Aug 18 14:19:24 2016 +1200

Bug 1554247 - Fixed attachment file links showing up on fullwidth layout

behatnotneeded

Change-Id: I00da7d2a319dacabc802c09f1a668f0f37db7057
(cherry picked from commit 76fe713b7624ae49d789d45a1b874e40fc18d56f)

Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.04.1 → 16.04.4
milestone: 16.04.4 → none
Robert Lyon (robertl-9) on 2016-10-25
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers