Profile pictures displayed incorrectly for staff on user search when no access list access

Bug #1545380 reported by Kristina Hoeppner on 2016-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
15.10
High
Unassigned

Bug Description

Mahara 15.10+

When you are a staff member and don't have access to the access list (in Administration -> Configure site -> Site options -> User settings -> "Staff report access" set to "No", the user search page doesn't display the profile pictures correctly, but all next to each other (see attachment).

It is fine when the setting is "yes" because then the "All/None" column is there.

description: updated

Also, the right side of the button "Get reports for selected users" is missing because there is no second button.

tags: added: usermanualupdate
Robert Lyon (robertl-9) on 2016-02-15
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/6060
Committed: https://git.mahara.org/mahara/mahara/commit/b5bf4d5da0febd4916dc0b8d2eb71470760f0671
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit b5bf4d5da0febd4916dc0b8d2eb71470760f0671
Author: Robert Lyon <email address hidden>
Date: Mon Feb 15 13:49:23 2016 +1300

Bug 1545380: Profile images on user list broken for staff

When 'Staff report access' is set to 'no'. This is due to the column
being built from both the 'select' and 'icon' part of the $cols array.

So need to pass in a mostly blank 'select' column info rather than
unset it.

Also fixed up the missing right side line on button when viewing page as
staff with 'Staff report access' set to 'yes'

behatnotneeded

Change-Id: I97d77f0dc136967efa16945114bcd990e49754d0
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed

Reviewed: https://reviews.mahara.org/6150
Committed: https://git.mahara.org/mahara/mahara/commit/c2b7e9203a6216be9edffe97bd138b55683468dd
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit c2b7e9203a6216be9edffe97bd138b55683468dd
Author: Robert Lyon <email address hidden>
Date: Mon Feb 15 13:49:23 2016 +1300

Bug 1545380: Profile images on user list broken for staff

When 'Staff report access' is set to 'no'. This is due to the column
being built from both the 'select' and 'icon' part of the $cols array.

So need to pass in a mostly blank 'select' column info rather than
unset it.

Also fixed up the missing right side line on button when viewing page as
staff with 'Staff report access' set to 'yes'

behatnotneeded

Change-Id: I97d77f0dc136967efa16945114bcd990e49754d0
Signed-off-by: Robert Lyon <email address hidden>
(cherry picked from commit b5bf4d5da0febd4916dc0b8d2eb71470760f0671)

Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers