Update Readme to handle supported Internet Explorer browsers better

Bug #1541174 reported by Kristina Hoeppner on 2016-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Kristina Hoeppner
15.04
Medium
Kristina Hoeppner
15.10
Medium
Kristina Hoeppner

Bug Description

We decided to make some changes to our support of IE browsers that are not officially supported anymore by Microsoft in the 50th developer meeting. See http://meetbot.mahara.org/mahara-dev/2016/mahara-dev.2016-02-02-07.34.log.html#l-163 for the discussion.

Change the wording for 15.04 and 15.10 that mahara will work with IE9 and 10 (Mahara 15.04) and IE10 (Mahara 15.10) browser versions but we recommend to use a supported version or different browser

Change wording for Mahara 16.04 that only Microsoft supported browsers are supported to a maximum of the three most recent ones. in this case right now it would be IE 11 and 12.

This will also include an update to the mobile browsers. From the dev meeting notes: https://wiki.mahara.org/wiki/Developer_Area/Developer_Meetings/50

It was agreed to start smoke-testing Mahara on mobile devices in the latest Safari (iOS) and Android Chrome (Android) browsers.

Changed in mahara:
status: Confirmed → In Progress

Mobile browser support only from Mahara 16.04 on.

Mahara Bot (dev-mahara) wrote :

Patch for "15.04_STABLE" branch: https://reviews.mahara.org/6093

Mahara Bot (dev-mahara) wrote :

Patch for "15.10_STABLE" branch: https://reviews.mahara.org/6094

Reviewed: https://reviews.mahara.org/6094
Committed: https://git.mahara.org/mahara/mahara/commit/9b4855515fcec678cbc8c27f5127f2297174b4e9
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 9b4855515fcec678cbc8c27f5127f2297174b4e9
Author: Kristina D.C. Hoeppner <email address hidden>
Date: Tue Mar 1 17:43:11 2016 +1300

Bug 1541174: Update Readme with supported IE browsers

This change is necessary because IE10 is not supported
by Microsoft anymore itself.

behatnotneeded

Change-Id: I3a3eca2cae274a54b98efce578aa14c2a20ced2e

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6092
Committed: https://git.mahara.org/mahara/mahara/commit/39e556b2417a406f29f09125a544a0b942b9a11f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 39e556b2417a406f29f09125a544a0b942b9a11f
Author: Kristina D.C. Hoeppner <email address hidden>
Date: Tue Mar 1 17:38:44 2016 +1300

Bug 1541174: Update Readme about supported browsers

behatnotneeded

Change-Id: Iac163d9bc762f1d132170b9845ed18311509c2ac

Robert Lyon (robertl-9) on 2016-03-02
Changed in mahara:
status: In Progress → Fix Committed
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6093
Committed: https://git.mahara.org/mahara/mahara/commit/054527cbc166dac320550cade0a453c2be776b67
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 054527cbc166dac320550cade0a453c2be776b67
Author: Kristina D.C. Hoeppner <email address hidden>
Date: Tue Mar 1 17:46:29 2016 +1300

Bug 1541174: Update Readme in regards to IE

This change is necessary because Microsoft
does not support IE9 and IE10 anymore. Thus,
we should not encourage their use.

behatnotneeded

Change-Id: Icc0690237e7fd4740d578266ed6ee033cd8661ed

Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers