Page comment moderation doesn't affect artefact comments

Bug #1540534 reported by Kristina Hoeppner on 2016-02-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
High
Son Nguyen
15.10
High
Unassigned
16.04
High
Unassigned
16.10
High
Unassigned

Bug Description

Seen on mahara.org and tested on latest master (16.04).

When you turn on comment moderation for a page, that moderation only goes for page comments but not artefact comments. Artefact comments should be treated the same in that regard as there is no separate moderation possibility. This loophole can be misused by anonymous people to post comments on an artefact that are immediately visible to everyone.

Aaron Wells (u-aaronw) wrote :

I suppose what we can do is take the view that the artefact is being viewed "from", and apply the moderation setting from that, to the artefact comments.

However, there's still a loophole in this, which is that an artefact can be viewed from multiple pages. So there's a high likelihood of a confusing case arising where a user has placed an artefact in two separate views, one with comment moderation enabled, and the other without. And if we ever implement individual artefact access, that will provide an even greater loophole; just access the artefact's page directly.

I think the "comment moderation" setting was probably originally devised without taking artefact comments into consideration. It would probably be a good idea to give it a good think and see if we can come up with a clever and more intuitive way to handle this. Like perhaps making a user's comment moderation setting global instead of per-page; or making it aware of "logged in" / "friend" / "logged-out".

What if we changed the comment section to turn on comments for both page and artefacts unless an artefact explicitly prohibits it and then apply the comment moderation? Having to allow comments on individual artefacts on a large page besides the page itself can be quite cumbersome. Tying that in with page comments would make this step quicker and reduce the overload when uploading files as you don't have to decide it there.

If the settings from the page are then pulled through to the artefact and some users need to go through moderation because they come from Page A instead of Page B that should be OK as they are likely very different user groups.

no longer affects: mahara/1.10
no longer affects: mahara/15.04
no longer affects: mahara/15.10
Changed in mahara:
milestone: 16.04.0 → 16.10.0

Aaron, the options you put on bug #1567138 seem to complicate things very much because you'll have to check in too many places whether for comment moderation and have to make more choices. I'd suggest that when artefact comments are allowed, they follow the same moderation principles as the page itself. Only when artefact comments are not allowed, nobody can comment no matter whether page comments are allowed or not.

I often set artefact comments to "No" for decorative images or images where I don't want any comments, e.g. a logo. Thus, the "No comments" setting should be respected.

Of course, if we moderate comments on one page but not another, comments could be placed directly, but that would be ok because some people would be exempted from the moderation queue.

Retagging for 15.10 and 16.04 as it can be an issue for sites that allow anonymous comments.

Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)
Son Nguyen (ngson2000) wrote :

When adding/editing comments to an artefact (see the script artefact/artefact.php and artefact/comment/edit.php), there is always a view associated to the artefact. The comment moderation setting for the view will be applied to its artefacts.

Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/7182
Committed: https://git.mahara.org/mahara/mahara/commit/74ee809f94afa7b2f603f258d4752d9fb71ab7c9
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 74ee809f94afa7b2f603f258d4752d9fb71ab7c9
Author: Son Nguyen <email address hidden>
Date: Thu Oct 20 11:26:38 2016 +1300

Bug 1540534: Apply the moderation setting from view to its artefacts

Change-Id: I974df9100f22a5c2bd5e1e78d6b8645d198f42eb
behatnotneeded: TODO: need to add a senario for this case

Robert Lyon (robertl-9) on 2016-10-31
Changed in mahara:
status: In Progress → Fix Committed
Mahara Bot (dev-mahara) wrote :

Patch for "16.04_STABLE" branch: https://reviews.mahara.org/7220

Mahara Bot (dev-mahara) wrote :

Patch for "15.10_STABLE" branch: https://reviews.mahara.org/7221

Reviewed: https://reviews.mahara.org/7221
Committed: https://git.mahara.org/mahara/mahara/commit/83007f1bad3516f67983ea21b49ea4bb355e3e1f
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 83007f1bad3516f67983ea21b49ea4bb355e3e1f
Author: Son Nguyen <email address hidden>
Date: Thu Oct 20 11:26:38 2016 +1300

Bug 1540534: Apply the moderation setting from view to its artefacts

Change-Id: I974df9100f22a5c2bd5e1e78d6b8645d198f42eb
behatnotneeded: TODO: need to add a senario for this case
(cherry picked from commit 74ee809f94afa7b2f603f258d4752d9fb71ab7c9)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/7220
Committed: https://git.mahara.org/mahara/mahara/commit/86c3756140c3c1903d133edcbb2edcbf8d692050
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.04_STABLE

commit 86c3756140c3c1903d133edcbb2edcbf8d692050
Author: Son Nguyen <email address hidden>
Date: Thu Oct 20 11:26:38 2016 +1300

Bug 1540534: Apply the moderation setting from view to its artefacts

Change-Id: I974df9100f22a5c2bd5e1e78d6b8645d198f42eb
behatnotneeded: TODO: need to add a senario for this case
(cherry picked from commit 74ee809f94afa7b2f603f258d4752d9fb71ab7c9)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/7219
Committed: https://git.mahara.org/mahara/mahara/commit/f0587208c59c9a6e21c8e8cb77516fd2c80b10d7
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.10_STABLE

commit f0587208c59c9a6e21c8e8cb77516fd2c80b10d7
Author: Son Nguyen <email address hidden>
Date: Thu Oct 20 11:26:38 2016 +1300

Bug 1540534: Apply the moderation setting from view to its artefacts

Change-Id: I974df9100f22a5c2bd5e1e78d6b8645d198f42eb
behatnotneeded: TODO: need to add a senario for this case
(cherry picked from commit 74ee809f94afa7b2f603f258d4752d9fb71ab7c9)

tags: added: usermanualupdate
tags: removed: usermanualupdate

I do not understand why the comments-configuration is something that belogs to the uploaded file itself. If you use a picture on many views and you change the comments-setting from the picture, then EVERY comments-setting in EVERY view is getting changed, isn't it?
I think that ther should not be the possibility to configure comments directly in the file-configuration. One small step is to disable comments for artefacts by default in the adminconfiguration.

Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers