Pending friends aren't shown on person's "My friends" page who sent the request

Bug #1530045 reported by Kristina Hoeppner on 2015-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Unassigned

Bug Description

When you send a friend request to someone, you request shows up as "Pending" on their "My friends" page. However, you don't see them as pending on your "My friends" page.

To test:

1. Send friend request to Paula (make sure that she doesn't have auto-accepting of friend requests turned on, which is the default)
2. Go to Groups -> My friends.
3. Expected result: You can see Paula listed as "Pending". Actual result: Paula doesn't show up at all.

We do keep the information that you requested friendship with Paula because when you search for her on "Find friends", you'll see that it states that you requested friendship.

Robert Lyon (robertl-9) on 2016-04-28
Changed in mahara:
milestone: 16.04.0 → 16.10.0
Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0
Changed in mahara:
milestone: 17.04.0 → none
Robert Lyon (robertl-9) on 2017-10-27
Changed in mahara:
status: Confirmed → In Progress
milestone: none → 18.04.0
Changed in mahara:
importance: Medium → Wishlist

Reviewed: https://reviews.mahara.org/8195
Committed: https://git.mahara.org/mahara/mahara/commit/32498d039bd8758b76e45fa4bfef31362add9285
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 32498d039bd8758b76e45fa4bfef31362add9285
Author: Robert Lyon <email address hidden>
Date: Fri Oct 27 22:22:44 2017 +1300

Bug 1530045: Show users one is trying to befriend on 'My friends' page

behatnotneeded

Change-Id: I7963cd4e454722991683d69b76fb5d6487769bfc
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2017-11-20
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers