Real name is displayed when it shouldn't be

Bug #1529753 reported by Kristina Hoeppner on 2015-12-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Unassigned
1.10
High
Unassigned
15.04
High
Unassigned
15.10
High
Unassigned

Bug Description

Mahara 15.10+

When users can hide their real name, but don't choose to do so, their real name appears in places where it did not appear in Mahara 15.04.

The option for hiding the real name only states: "Check this box if you have set a display name and do not want other users to be able to find you by your real name in user searches."

That means, that they can be found by their real name, but it doesn't say that their real name is also displayed around the site alongside their display name. Regular users see the real name of a person displayed now in more places than before making it more cumbersome to read the name.

Examples where the real name besides the display name is shown but wasn't in Mahara 15.04:

- "Online users" sideblock
- "Shared with me"
- Group homepage if the user is a group admin
- on group members page

Marked as high priority because it could be a privacy concern for users who deliberately choose not to display their entire name but use a display name.

Update to this. From the mentioned places where a user's real name was shown rather than their display name, only the group members page was a problem when the user was invited to the group and still a pending member. All good ones she was a real member.

Steps to replicate:

1. Create three accounts: One site admin and two regular users (A and B).
2. As site admin, allow users to hide their real name under Config site -> Site options -> User settings
3. Log in as A and set the display name to "Display name".
4. Log in as B, create a group and on the member's page click on "Send multiple invitations at once".

Expected result: In the box "Potential members" I see user A listed as "Display name".
Actual result: I just see A for both, Potential members and Users to be invited. This is wrong as no display name is displayed at all.

If as administrator I don't see the display name but only the real name and the username.

This is the case in all the boxes, e.g. also on the institution members, staff and administrators pages in the administration.

In addition on the group members page, when I invited user A and check out the "Invites" in the list of members, I see the real name instead of the display name.

Robert Lyon (robertl-9) wrote :

The group members box should be working now

The boxes for the admin section display the user names slightly different and as admins can see real names regardless I'll leave them as is.

Changed in mahara:
status: Confirmed → In Progress
Aaron Wells (u-aaronw) wrote :

This bug (with the display name being shown in the group member invite screen) is actually *not* a regression. It's present at least as far back as Mahara 1.10. So, since it's high priority and a privacy bug, I'm tagging it for backporting to all the supported versions.

Reviewed: https://reviews.mahara.org/6141
Committed: https://git.mahara.org/mahara/mahara/commit/564caacd8753a5c780526ad023d29ff9298096f8
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 564caacd8753a5c780526ad023d29ff9298096f8
Author: Robert Lyon <email address hidden>
Date: Tue Mar 15 15:04:56 2016 +1300

Bug 1529753: Passing through the preferred name value

When displaying names for adding group members to groups

behatnotneeded

Change-Id: I0fb09eb1a17bd94c58533b8272db38e439897cbe
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Patch for "15.04_STABLE" branch: https://reviews.mahara.org/6153

Mahara Bot (dev-mahara) wrote :

Patch for "1.10_STABLE" branch: https://reviews.mahara.org/6154

Reviewed: https://reviews.mahara.org/6152
Committed: https://git.mahara.org/mahara/mahara/commit/e01d97b7860d10b91fd203cf4bb7fd0853d99fd2
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit e01d97b7860d10b91fd203cf4bb7fd0853d99fd2
Author: Robert Lyon <email address hidden>
Date: Tue Mar 15 15:04:56 2016 +1300

Bug 1529753: Passing through the preferred name value

When displaying names for adding group members to groups

behatnotneeded

Change-Id: I0fb09eb1a17bd94c58533b8272db38e439897cbe
Signed-off-by: Robert Lyon <email address hidden>
(cherry picked from commit 564caacd8753a5c780526ad023d29ff9298096f8)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6153
Committed: https://git.mahara.org/mahara/mahara/commit/215e33691dffa52cba042442be1678c10be52d0e
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 215e33691dffa52cba042442be1678c10be52d0e
Author: Robert Lyon <email address hidden>
Date: Tue Mar 15 15:04:56 2016 +1300

Bug 1529753: Passing through the preferred name value

When displaying names for adding group members to groups

behatnotneeded

Change-Id: I0fb09eb1a17bd94c58533b8272db38e439897cbe
Signed-off-by: Robert Lyon <email address hidden>
(cherry picked from commit 564caacd8753a5c780526ad023d29ff9298096f8)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/6154
Committed: https://git.mahara.org/mahara/mahara/commit/23210afcf509ff44a1f0b62d3e65406aa6ce9433
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit 23210afcf509ff44a1f0b62d3e65406aa6ce9433
Author: Robert Lyon <email address hidden>
Date: Tue Mar 15 15:04:56 2016 +1300

Bug 1529753: Passing through the preferred name value

When displaying names for adding group members to groups

behatnotneeded

Change-Id: I0fb09eb1a17bd94c58533b8272db38e439897cbe
Signed-off-by: Robert Lyon <email address hidden>
(cherry picked from commit 564caacd8753a5c780526ad023d29ff9298096f8)

Changed in mahara:
status: Fix Committed → Fix Released
no longer affects: mahara/16.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers