Make screens in group more consistent with headings

Bug #1529731 reported by Kristina Hoeppner on 2015-12-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Liam
15.10
Medium
Unassigned

Bug Description

Mahara 15.10+

In Mahara 15.10 we introduced the third level navigation for groups (instead of tabs) and also decided to always show the group name in the main heading for the page you are currently on. This is already the case for the main pages (About, Members, Pages, Collections etc.).

However, a number of sub pages do not yet follow this pattern. For example, when you are inviting friends at /group/inviteusers.php you only see the group name, but not "Members | Group name". I think this should be changed on the screens where the group navigation is visible to be consistent.

Changed in mahara:
assignee: Pat (pat-kira) → nobody
Liam (liam-sharpe) on 2016-01-26
Changed in mahara:
assignee: nobody → Liam (liam-sharpe)
status: Confirmed → Won't Fix
status: Won't Fix → In Progress

Reviewed: https://reviews.mahara.org/5969
Committed: https://git.mahara.org/mahara/mahara/commit/ed07c1f9e06dc929e4eaf3a28f8c4cfa10a62fc7
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ed07c1f9e06dc929e4eaf3a28f8c4cfa10a62fc7
Author: Liam Sharpe <email address hidden>
Date: Wed Jan 27 14:01:57 2016 +1300

Make screens in group more consistent with headings - Bug #1529731

behatnotneeded

Change-Id: Id7a00baaf29c947a70ce2b9cad209f38c06dff06

Robert Lyon (robertl-9) on 2016-01-27
Changed in mahara:
status: In Progress → Fix Committed
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/5981

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/5982

Reviewed: https://reviews.mahara.org/5982
Committed: https://git.mahara.org/mahara/mahara/commit/9bbadef214d6b74fb4507ebdf2057adfb5d8f113
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 9bbadef214d6b74fb4507ebdf2057adfb5d8f113
Author: Liam Sharpe <email address hidden>
Date: Fri Jan 29 13:18:57 2016 +1300

Added members subsection heading to reccomend groups page - Bug #1529731

behatnotneeded

Change-Id: I7648e3e12c660704f416e78e65060fbe1d3a4a07

Reviewed: https://reviews.mahara.org/5976
Committed: https://git.mahara.org/mahara/mahara/commit/5226c08443956373ec7fc82ca6581442b267e30d
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 5226c08443956373ec7fc82ca6581442b267e30d
Author: Liam Sharpe <email address hidden>
Date: Wed Jan 27 14:01:57 2016 +1300

Make screens in group more consistent with headings - Bug #1529731

behatnotneeded

Change-Id: Id7a00baaf29c947a70ce2b9cad209f38c06dff06
(cherry picked from commit ed07c1f9e06dc929e4eaf3a28f8c4cfa10a62fc7)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5993
Committed: https://git.mahara.org/mahara/mahara/commit/2bc8e6a24e92a697ef717e101fdae21ec8f77924
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 2bc8e6a24e92a697ef717e101fdae21ec8f77924
Author: Liam Sharpe <email address hidden>
Date: Fri Jan 29 13:18:57 2016 +1300

Added members subsection heading to reccomend groups page - Bug #1529731

behatnotneeded

Change-Id: I7648e3e12c660704f416e78e65060fbe1d3a4a07
(cherry picked from commit 9bbadef214d6b74fb4507ebdf2057adfb5d8f113)

Aaron Wells (u-aaronw) wrote :

Hi Robert,

Since you've recently worked on all these header constants, can you please add them to the developer docs? https://wiki.mahara.org/wiki/Developer_Area/Pagetop_Constants

Cheers,
Aaron

Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers