Broken links in installer

Bug #1523499 reported by Stanislav Tsymbalov on 2015-12-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Unassigned
1.10
Low
Unassigned
15.04
Low
Unassigned
15.10
Low
Unassigned

Bug Description

Hi,
when I just started install Mahara 15.10 I saw the message "Before you install Mahara, you may want to check out the release notes for this release.".

But link to release notes (https://wiki.mahara.org/Release_Notes/15.10.0) is broken.
True link is https://launchpad.net/mahara/15.10/15.10.0#release-notes

description: updated
Aaron Wells (u-aaronw) on 2015-12-07
Changed in mahara:
importance: Undecided → Low
status: New → Confirmed
summary: - Broken link to release notes
+ Broken links in installer
Aaron Wells (u-aaronw) wrote :

Thanks for the bug report! We have got some broken legacy redirects due to a recent upgrade of the wiki software on https://wiki.mahara.org

I thought I'd fixed them all but it looks like a couple slipped through the cracks.

Aaron Wells (u-aaronw) wrote :

Wrote up a quick script to help me identify and test every URL in the Mahara code base, and updated all the ones that were out of date and/or broken.

https://git.mahara.org/scripts/mahara-scripts/blob/master/tools/urltest.php

Reviewed: https://reviews.mahara.org/5829
Committed: https://git.mahara.org/mahara/mahara/commit/4c046f3d456badf4a9340b1dab6fc2dd34d517cb
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 4c046f3d456badf4a9340b1dab6fc2dd34d517cb
Author: Aaron Wells <email address hidden>
Date: Wed Dec 9 18:08:05 2015 +1300

Updating outdated links in the Mahara source code

Bug 1523499: Old wiki.mahara.org links without the "/wiki",
and HTTP links that should be HTTPS.

Also updated the installer release notes link to point to
the base "Release_Notes" page in the wiki, because we no
longer maintain separate wiki pages for each release.

behatnotneeded: Covered by existing tests

Change-Id: I02e80eb4d8df5adddee88e77156e8e103ca24c51

Mahara Bot (dev-mahara) wrote :

Patch for "15.04_STABLE" branch: https://reviews.mahara.org/5834

Mahara Bot (dev-mahara) wrote :

Patch for "1.10_STABLE" branch: https://reviews.mahara.org/5835

Reviewed: https://reviews.mahara.org/5833
Committed: https://git.mahara.org/mahara/mahara/commit/ca01f231d242ebce1818e43ad70c543812503da2
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit ca01f231d242ebce1818e43ad70c543812503da2
Author: Aaron Wells <email address hidden>
Date: Wed Dec 9 18:08:05 2015 +1300

Updating outdated links in the Mahara source code

Bug 1523499: Old wiki.mahara.org links without the "/wiki",
and HTTP links that should be HTTPS.

Also updated the installer release notes link to point to
the base "Release_Notes" page in the wiki, because we no
longer maintain separate wiki pages for each release.

behatnotneeded: Covered by existing tests

Change-Id: I02e80eb4d8df5adddee88e77156e8e103ca24c51
(cherry picked from commit 4c046f3d456badf4a9340b1dab6fc2dd34d517cb)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5834
Committed: https://git.mahara.org/mahara/mahara/commit/35fc0e18fcbfcdc5c530e201cf771e84168da51c
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 35fc0e18fcbfcdc5c530e201cf771e84168da51c
Author: Aaron Wells <email address hidden>
Date: Wed Dec 9 18:08:05 2015 +1300

Updating outdated links in the Mahara source code

Bug 1523499: Old wiki.mahara.org links without the "/wiki",
and HTTP links that should be HTTPS.

Also updated the installer release notes link to point to
the base "Release_Notes" page in the wiki, because we no
longer maintain separate wiki pages for each release.

behatnotneeded: Covered by existing tests

Change-Id: I02e80eb4d8df5adddee88e77156e8e103ca24c51
(cherry picked from commit 4c046f3d456badf4a9340b1dab6fc2dd34d517cb)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5835
Committed: https://git.mahara.org/mahara/mahara/commit/dbc2403e64c575c05a9bc3935b67d81514db9cd8
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit dbc2403e64c575c05a9bc3935b67d81514db9cd8
Author: Aaron Wells <email address hidden>
Date: Wed Dec 9 18:08:05 2015 +1300

Updating outdated links in the Mahara source code

Bug 1523499: Old wiki.mahara.org links without the "/wiki",
and HTTP links that should be HTTPS.

Also updated the installer release notes link to point to
the base "Release_Notes" page in the wiki, because we no
longer maintain separate wiki pages for each release.

behatnotneeded: Covered by existing tests

Change-Id: I02e80eb4d8df5adddee88e77156e8e103ca24c51
(cherry picked from commit 4c046f3d456badf4a9340b1dab6fc2dd34d517cb)

no longer affects: mahara/16.04
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers