No button for choose a folder

Bug #1517478 reported by Stefanie Berger on 2015-11-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
High
Pat
15.10
High
Unassigned

Bug Description

Add a folder to a page. You will get the Edit popup on the right side. There you have to open the section "Folders" and choose a folder. Here is missing a selection button. You have to click on a white place. A click on the folder name to open a new folder, but does not select him.

Version: 15.10.0
Postgres Version 9.1

Aaron Wells (u-aaronw) wrote :

Hi Stefanie,

Thanks for the bug report! That is a bit of a usability bug. It breaks the pattern established by the other file blocks (like the image block) where you can click on the file's thumbnail in order to select it.

Pat,

Do you have any ideas on this one? We do need people to be able to open the folder in case they want to select a child folder. But as it currently stands, it's not really clear *what* you're supposed to click on.

Cheers,
Aaron

Changed in mahara:
importance: Undecided → Low
status: New → Confirmed
tags: added: usability
Colin (gamerlearner) wrote :

Thanks for posting this Stefanie, it has been driving me insane for hours.

This is a major usability problem as there is no logical reason to think that you wouldn't click either on the name of the folder in the folder list or on the folder & + symbol icon next to it.

(I can see now that clicking the name of the folder shows you any subfolders that are in it, so I can understand why clicking the name of the folder shouldn't add it to the page)

The user guide for version 15.10 specifically states that we should click the Select button, which made me think that our install was broken. At the very least could you please update this page with an accurate screenshot.

http://manual.mahara.org/en/15.10/blocks/files.html#folder

I appreciate that this bug doesn't stop Mahara from working but I hope that it can be given a higher priority than Low as it does effectively remove a key piece of functionality from the tool. (And hopefully it shouldn't be too hard to fix)

cheers
Colin

Aaron Wells (u-aaronw) wrote :

Well, here's the general criteria we use for setting the "Importance" field: https://wiki.mahara.org/wiki/Developer_Area/Bug_Status#Bug_importance . I saw this as a "Usability problem that causes moderate or minor inconvenience", and "Easy workaround is available", i.e. click the white space. So, "Low" importance.

But I suppose if the folder block sees heavy usage, that might merit raising the importance level.

Unfortunately it's a tricky one to fix, because no longer use those "select" buttons anywhere. So it needs a bit of creativity to figure out how this one should work so that it won't be too inconsistent with how the other file pickers work.

Cheers,
Aaron

Domi Sinclair (domi-sinclair) wrote :

I would second this.

I think with the select a thumbnail on other files/ image this can also be confusing if you don't know. Perhaps having a select button for everything would be more consistent and cleaner for the user.

We've had a reports of Mahara being 'broken' and it turns out they just didn't know to click the random blank space under description to select a folder for a page. I too thought it was broken when I first tested Mahara 15.10 but once we figured it out it worked. I had reporting this on my to-do list for today. Glad to see it has already come up :)

Aaron Wells (u-aaronw) wrote :

Okay, if students are reporting it "broken", I'll bump it to "High".

Reducing the perceived "brokenness" of Mahara is one of my top priorities. ;)

Cheers,
Aaron

Thanks, Aaron! :-)

Bringing back the "Select" button sounds like the best thing to do.

tags: added: bootstrap

P.S. The user manual hadn't been updated in November for that part yet. It's been done for a few weeks now. Sorry for the delay on it.

Currently, in master actually when you click a file name, it selects the file instead of downloading it (like it says on the tooltip). Thus, we'd need to change to tooltip to "Select..." and for the folder make the folder name clickable. You can still reach the sub folders by clicking the folder icon as it has a plus in front of it. The Select button would still be nice as additional queue, but there might have been a problem in Bootstrap with it and that's why it's not there anymore.

Reviewed: https://reviews.mahara.org/6307
Committed: https://git.mahara.org/mahara/mahara/commit/6d2047583e0cc795bf8c48bf3b4431b449c76f3e
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 6d2047583e0cc795bf8c48bf3b4431b449c76f3e
Author: Pat Kira <email address hidden>
Date: Tue Apr 5 10:49:44 2016 +1200

bug 1517478 - Add select button to filebrowser

Allowing the select button to appear on group/institution places

behatnotneeded

Change-Id: Ie58ff61b915753c2de5e9f60cf8d17b345b0b6e4

I've patched it and it works fine in all themes (15.10.2) (y)

Reviewed: https://reviews.mahara.org/6319
Committed: https://git.mahara.org/mahara/mahara/commit/231dcf4bcc35620d125b44574dce78f0dd45365f
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 231dcf4bcc35620d125b44574dce78f0dd45365f
Author: Pat Kira <email address hidden>
Date: Tue Apr 5 10:49:44 2016 +1200

bug 1517478 - Add select button to filebrowser

Allowing the select button to appear on group/institution places

behatnotneeded

Change-Id: Ie58ff61b915753c2de5e9f60cf8d17b345b0b6e4

Reviewed: https://reviews.mahara.org/6323
Committed: https://git.mahara.org/mahara/mahara/commit/d176266fc9240e541b2f53acac5bc85879b732cc
Submitter: Robert Lyon (<email address hidden>)
Branch: 16.04_STABLE

commit d176266fc9240e541b2f53acac5bc85879b732cc
Author: Pat Kira <email address hidden>
Date: Tue Apr 5 10:49:44 2016 +1200

bug 1517478 - Add select button to filebrowser

Allowing the select button to appear on group/institution places

behatnotneeded

Change-Id: Ie58ff61b915753c2de5e9f60cf8d17b345b0b6e4
(cherry picked from commit 6d2047583e0cc795bf8c48bf3b4431b449c76f3e)

Thanks for your feedback, Stefanie!

tags: added: usermanualupdate
no longer affects: mahara/16.04
Changed in mahara:
status: Fix Committed → Fix Released
tags: removed: usermanualupdate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers