Show friend portfolio activity on your dashboard

Bug #1516981 reported by Gregor Anželj on 2015-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Gregor Anželj

Bug Description

Enhance the "Watched pages" block to configure it so as to display changes relating to users' friends since their last login, as discussed on 48th Mahara dev meeting.

The upgrade of functionality will be funded by Donau-Universität Krems as a part of ATS2020 project.

Changed in mahara:
assignee: nobody → Gregor Anželj (gregor-anzelj)
description: updated
Aaron Wells (u-aaronw) on 2015-11-17
Changed in mahara:
importance: Undecided → Wishlist
status: New → Confirmed
milestone: none → 16.04.0
tags: added: watchlist
Changed in mahara:
status: Confirmed → In Progress

How to test:

1. Create a page as an admin and share it with registered users
2. Create a user as an admin
3. Log in as the created user
4. Put the "shared page created by admin in step 1" on the user's watchlist
5. Edit the "watched pages block" for the user you have logged in as
6. Select "Activities of my friends" for "List type show" on the edit screen
7. Click on the additional filters and settings and do the following:
8. Select "All activities from "Filter by activity type" drop down menu, select "a time period" from "Filter by time", select "Activity type" from the "Order by" drop down menu and save.
9. Log in as admin again and make some changes to some page created earlier
10. Log back in as the user --> on the dashboard user should see an "update by admin" in the "Latest changes I can view" block
11. Repeat "step 5 as the user" and select "Pages on my watchlist" from the edit screen then save.
12. Repeat "step 9 as admin" and make changes to the shared page created earlier
13. Log in as the user --> on the "watched pages block" there should be "an update and date" by the admin
14. User should see the inbox updated with a message --> clicking on it displays activities taken on the page.

Spinning loading icon when editing page in Firefox

Spinning loading icon when editing page in Firefox

"Page1" activities from watched pages.

Gregor and I had a chat today and I found out a bit more:

- When you select the activity of your friends, their pages don't need to be on the watchlist.
- Normally watched pages run on a cron job, but the friend activity doesn't and should update the block immediately.
- Friend activity doesn't generate notifications.
- "Friend activity" means "Shared with me as a friend", i.e. by being on the "Friend" list but it can also be for pages updated when they are just shared with me personally and me being on the list of friends.

Aaron Wells (u-aaronw) on 2016-04-28
Changed in mahara:
milestone: 16.04.0 → 16.10.0
Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0

Reviewed: https://reviews.mahara.org/6059
Committed: https://git.mahara.org/mahara/mahara/commit/3ca8f0bef491ae9f7b80620e2a0a213cc597fc03
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 3ca8f0bef491ae9f7b80620e2a0a213cc597fc03
Author: Gregor Anzelj <email address hidden>
Date: Sun Feb 14 15:59:19 2016 +0100

Enhance the Watchlist block (Bug #1516981)

Enhance the "Watched pages" block to configure it so as to
display changes relating to users' friends since their last
login of different time frame (e.g. last week, last month,
last quarter, last year, etc.).

behatnotneeded: Tests will be written later.

Change-Id: I0ed978a5070120e5b32e79d25f99c2bca84feb20
Signed-off-by: Gregor Anzelj <email address hidden>

Robert Lyon (robertl-9) on 2017-03-21
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
summary: - Enhance the Watchlist block
+ Show friend portfolio activity on your dashboard
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers