Minor menu issue on Send Message page

Bug #1507980 reported by Bernard Neary on 2015-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Robert Lyon
15.10
Low
Robert Lyon

Bug Description

Version: 15.10rc2
OS: Windows 7
Browser: Firefox 41.0.2

Link:
http://master.dev.mahara.org/module/multirecipientnotification/sendmessage.php

The default text 'Type in a search term' in the Recipients text box is appearing through the menu. Under Groups, 'Find Friends', 'Institution membership' and 'Topics' are not clickable from the 'Send Message' page. The text also appears through the Portfolio and Content menus, but it does not prevent the sub pages of these menu items from been clicked.

Bernard Neary (bneary) wrote :
Robert Lyon (robertl-9) wrote :

I'll mark this as low priority as one can get around this issue by navigating elsewhere then to the un-clickable links

The issue is due to the z-index of items not being in the correct order

Changed in mahara:
importance: Undecided → Low
milestone: none → 16.04.0
status: New → In Progress
assignee: nobody → Robert Lyon (robertl-9)

Reviewed: https://reviews.mahara.org/5802
Committed: https://git.mahara.org/mahara/mahara/commit/20dba6595b4fdf7ddb88f49a87c6ec057c02763b
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 20dba6595b4fdf7ddb88f49a87c6ec057c02763b
Author: Robert Lyon <email address hidden>
Date: Sat Nov 28 13:06:11 2015 +1300

Bug 1507980: The z-index of select2 is too high

We need to have the z-index of the select2 search container
to be lower than the navigation menu z-index

behatnotneeded: design issue

Change-Id: I8daa8a67e0c7fa011728a23f3c25e68fd4a3b7f9
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/5813
Committed: https://git.mahara.org/mahara/mahara/commit/5d8054869afb7b135ac41f1c6e8aa9a85386b98e
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.10_STABLE

commit 5d8054869afb7b135ac41f1c6e8aa9a85386b98e
Author: Robert Lyon <email address hidden>
Date: Sat Nov 28 13:06:11 2015 +1300

Bug 1507980: The z-index of select2 is too high

We need to have the z-index of the select2 search container
to be lower than the navigation menu z-index

behatnotneeded: design issue

Change-Id: I8daa8a67e0c7fa011728a23f3c25e68fd4a3b7f9
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-12-02
Changed in mahara:
status: In Progress → Fix Committed
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers