Add OpenSans as default font into TinyMCE

Bug #1496676 reported by Kristina Hoeppner on 2015-09-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Pat

Bug Description

Mahara 15.10+

It would be good to add OpenSans, the default font from Mahara 15.10 on, into TinyMCE so it can be chosen if somebody wants to go back to the default font.

Aaron Wells (u-aaronw) on 2015-10-23
Changed in mahara:
milestone: 15.10.0 → 16.04.0
Aaron Wells (u-aaronw) on 2016-04-28
Changed in mahara:
milestone: 16.04.0 → 16.10.0
Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0
tags: added: front-end
Pat (pat-kira) on 2017-03-20
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Pat (pat-kira)

Reviewed: https://reviews.mahara.org/7545
Committed: https://git.mahara.org/mahara/mahara/commit/08cbbdf23da6f27a8700160bed02a27bfedeb3b0
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 08cbbdf23da6f27a8700160bed02a27bfedeb3b0
Author: Pat Kira <email address hidden>
Date: Mon Mar 20 17:17:40 2017 +1300

Bug 1496676 - Added Open Sans to font family list in tinyMce

- Added Open Sans to tinyMce default font list

Note: Since we probably want to keep the default font families defined by
tinyMce. The font_formats value(string) needs to include the default
value as there isn't an easier way to add to default font family string.

https://www.tinymce.com/docs/configure/content-formatting/#font_formats

behatnotneeded

Change-Id: If36bbd7dbd10db83e5b76468025deb30dba1bdc7

Robert Lyon (robertl-9) on 2017-03-20
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers