Fixing behat tests post bootstrap merge

Bug #1465462 reported by Robert Lyon on 2015-06-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Undecided
Unassigned

Bug Description

A generic bug for the fixing up of behat tests post bootstrap merge.

Things to consider when fixing behat tests:

1) Is it broken because of a regression of a recent patch - try and re merge missing code

2) Is broken because the bootstrap way is different - try and fix behat test

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4845

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4846

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4847

Reviewed: https://reviews.mahara.org/4846
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/ab8a80a7e7519906d9b6459dfaeb0a1b5dfb38c5
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ab8a80a7e7519906d9b6459dfaeb0a1b5dfb38c5
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 15:56:06 2015 +1200

Removing obsolete top submit button from profile (Bug #1465462)

This top submit button was used before we split the edit profile
page into tabs. The old tab JS used to remove it from the page.
The new Bootstrap JS does not remove it, and this causes problems
for Behat. But since we no longer support non-JS operation, it
makes more sense to remove it.

Change-Id: I38c5e451d018e47dc0704fe61892632431ec0c03

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4845
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/bfb2f83faf5ff9324c23487abd98d731595cf138
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit bfb2f83faf5ff9324c23487abd98d731595cf138
Author: Robert Lyon <email address hidden>
Date: Tue Jun 16 15:07:37 2015 +1200

Fixing up behat follow nav menu functions (Bug #1465462)

Now that navigation is structured differently

Change-Id: I8f8ac1e6613a9cf4061652fa61572655377a43a7
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4844
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/ac66401583adb1e47cfb765212c2917f41d8ed47
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit ac66401583adb1e47cfb765212c2917f41d8ed47
Author: Robert Lyon <email address hidden>
Date: Tue Jun 16 14:14:47 2015 +1200

Fixing up behat tests post bootstrap merge (Bug #1465462)

Change-Id: I33197a9f77d72f3b0f98e9d14e8f8cae1da7c2c6
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4850

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4851

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4853

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4854

Reviewed: https://reviews.mahara.org/4847
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/18a21818412553a70e7be1acb20b05dda3ad7087
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 18a21818412553a70e7be1acb20b05dda3ad7087
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 16:34:31 2015 +1200

Updating friend request Behat test (Bug 1465462)

Change-Id: Ie4275439efc528bb39615204d5c4cd4c83ee33d6

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4856

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4858

Reviewed: https://reviews.mahara.org/4849
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/ae51a6f4ed7002b8aa4717c12dc6ac56bc795da4
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ae51a6f4ed7002b8aa4717c12dc6ac56bc795da4
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 17:08:21 2015 +1200

Update Behat "expand fieldsets" command (Bug 1465462)

The HTML for this has changed because of Bootstrap.

Change-Id: I503c6c9c616c53aa3b64230ac669fff8c0c68369

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4850
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/713531022f5d4ec5b97aaccb8e6133a77aafcfe1
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 713531022f5d4ec5b97aaccb8e6133a77aafcfe1
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 18:25:56 2015 +1200

Adding a space back to navigation headers for Behat (Bug 1465462)

The {strip} Dwoo tags in this template strip out any spaces
that are at the start or end of a line, so I need to move this
space into the middle of a line. This will make it more readable
for automated tools like Behat.

Change-Id: I34b99f83c0752d00f3c313179ecbb46f469e8943

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4851
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/b840330799d2a706e4e0d09707407059403898bf
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit b840330799d2a706e4e0d09707407059403898bf
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 18:42:38 2015 +1200

Updating Notification Settings Order test (Bug 1465462)

This test was failing because it contain a lot of hard-coded
DOM selectors which changed under behat.

Change-Id: Icec982e5adb1445e8ff2240e84dadccf44e1ec4d

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4853
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/0d24ccfe73a727bd47b4df21b7ee62aad6460962
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 0d24ccfe73a727bd47b4df21b7ee62aad6460962
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 19:07:34 2015 +1200

Updating the "random clicking" test (Bug 1465462)

With the Behat changes, the activity type filter and the
"mark as read" buttons are no longer present in your inbox
until after you've received some messages.

So, those would be better moved to a more focused inbox test,
rather than being in "random clicking".

I've added some additional random clicks in the inbox screen
to make up for it. ;)

Change-Id: I4388320b95b1e7d508a04367afca283de167e6d3

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4854
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/ba422fb1129d396cd6aa15d8f1f520cc862c023c
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ba422fb1129d396cd6aa15d8f1f520cc862c023c
Author: Aaron Wells <email address hidden>
Date: Tue Jun 16 19:17:09 2015 +1200

Updating the "register site" data test (Bug 1465462)

Change-Id: I2937a2c727578879153f3b54865fda092dea11fc

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4856
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/f032808b147bb90c43d0d3bc95177e8177c2f167
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit f032808b147bb90c43d0d3bc95177e8177c2f167
Author: Robert Lyon <email address hidden>
Date: Wed Jun 17 09:56:39 2015 +1200

Bug 1465462: Fixing behat test for webservices

The first fieldset is expanded by default now

Change-Id: Ie9cb9a1422f3e8f86dcd4e5bcb69a56fd138dd6f
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4858
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/5f1d91db9e8ecd8e82d0b1b4e448e164421b2dfd
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 5f1d91db9e8ecd8e82d0b1b4e448e164421b2dfd
Author: Robert Lyon <email address hidden>
Date: Wed Jun 17 12:43:55 2015 +1200

Bug 1465462: Fixing webservices js for config page

For post bootstrap merge

Change-Id: Ib4e78760497ffbcbe8c7df320a1ba50d93098961
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4866

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4863
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/885fa727920684f6de2f9eaabe5db3bb5cb1dd33
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 885fa727920684f6de2f9eaabe5db3bb5cb1dd33
Author: Robert Lyon <email address hidden>
Date: Wed Jun 17 16:18:26 2015 +1200

Bug 1465462: Fixing problem with adding a block via click

The accessibility way of adding an item

Change-Id: I186ca63407bdc372e68537a242522cb4ec3c43c1
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4866
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/57ec07853f766b75ca442041af9f93979303de17
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 57ec07853f766b75ca442041af9f93979303de17
Author: Robert Lyon <email address hidden>
Date: Wed Jun 17 20:39:58 2015 +1200

Bug 1465462: adjusting behat steps to deal with new text

Change-Id: I2f7063a841f2bb473f93b03cde20c9c2a0633189
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4868

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4869

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4870

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4871

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4872

Reviewed: https://reviews.mahara.org/4867
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/d00758b16da20e73a0aee1e0fcc2f47ef0758192
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit d00758b16da20e73a0aee1e0fcc2f47ef0758192
Author: Robert Lyon <email address hidden>
Date: Thu Jun 18 12:23:37 2015 +1200

Bug 1465462: more behat fixes - this time in group section

Change-Id: I70974af717a97d838b60ff9289d68a74a94e8789
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4868
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/73cd20aa282e7295a914fb631499f5c75ed4fff7
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 73cd20aa282e7295a914fb631499f5c75ed4fff7
Author: Robert Lyon <email address hidden>
Date: Thu Jun 18 13:13:21 2015 +1200

Bug 1465462: fixing behat interaction section

Change-Id: I209a33b4ce57e0db0565beea132be4dc7eae7b12
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4869
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/4b88a51364a9971075bd1ccdb4ca20199c0f5348
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 4b88a51364a9971075bd1ccdb4ca20199c0f5348
Author: Robert Lyon <email address hidden>
Date: Thu Jun 18 14:16:55 2015 +1200

Bug 1465462: fixing up behat tests in notifications section

For activity_type_messages.feature we need to add some emails first or
otherwise the form field is not present. To do: make this a direct add
to db step for faster testing

Change-Id: I4ddca6465bdba912b66298d0656867ed9d588606
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4870
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/46e8bc8c21e021cc89d71b3efde176228901bca2
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 46e8bc8c21e021cc89d71b3efde176228901bca2
Author: Robert Lyon <email address hidden>
Date: Thu Jun 18 14:36:23 2015 +1200

Bug 1465462: fixing behat tests for users section

Change-Id: I101b96a215dc7139e0363ea009963c872f5952cc
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4871
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/921dcf47c6ff7de2bc00fb9de9992e01eb8bdbba
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 921dcf47c6ff7de2bc00fb9de9992e01eb8bdbba
Author: Robert Lyon <email address hidden>
Date: Thu Jun 18 16:48:23 2015 +1200

Bug 1465462: fixing behat tests for views section

Change-Id: Ibbb79edbea668b80c110abfac60db201a0045666
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4872
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/0dee5e3555cb593bb0f0aa9b138915137be44a97
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 0dee5e3555cb593bb0f0aa9b138915137be44a97
Author: Robert Lyon <email address hidden>
Date: Thu Jun 18 21:35:26 2015 +1200

Bug 1465462: more fixing behat tests for artefact section

Change-Id: I993ec4578cbee5456aa963a741458a9208adbe35
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-06-19
Changed in mahara:
status: New → Fix Committed
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4855
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/31f4da8e3b1e10a8f980cbda1d7195d17308e52d
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 31f4da8e3b1e10a8f980cbda1d7195d17308e52d
Author: Robert Lyon <email address hidden>
Date: Wed Jun 17 09:37:34 2015 +1200

Bug 1465462: Fixing missing variable error on cookieconsent page

Change-Id: I15c7b275790c8b1a9aeb49201abe0ba95f9df4bd
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4956
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/db92ab4de31b94783d061f991a07e0cf56552016
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit db92ab4de31b94783d061f991a07e0cf56552016
Author: Robert Lyon <email address hidden>
Date: Wed Jun 17 20:39:58 2015 +1200

Bug 1465462: adjusting behat steps to deal with new text

Change-Id: I2f7063a841f2bb473f93b03cde20c9c2a0633189
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2016-11-06
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers