Navigation group pages

Bug #1454458 reported by mike on 2015-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Jono Mingard
1.10
Medium
Unassigned
15.04
Medium
Unassigned
15.10
Undecided
Unassigned

Bug Description

Mahara version: 1.10.3+patches (latest version is 15.04.0)

This is for http://myportfolio.ac.nz/

If you have enough group pages they are split in lots of 5. If there is a group page that is able to be copied once you navigate to the second page you cannot nav back to page 1.

To Replicate:

Create a brand new group.

Make 7 or 8 group pages in the group (they can be empty pages, don’t change any other settings).

Note that the list of group pages on the group dashboard page only shows five, and you can go forward and back to view the next five then back to viewing the first five in the list.

Now, make one of the pages (such as the third page on the list) copiable.

Now try navigating forwards and backwards through the list of pages on the group dashboard.

If you made the third page copiable, it will let you go to “page 2” of the list of pages, but not go back. We have established that any list that contains a copiable page seems to bug out the forward and back buttons on the group dashboard page.

Jono Mingard (mingard) on 2015-05-15
Changed in mahara:
status: New → Confirmed
Jono Mingard (mingard) wrote :

OK, this happens because (in theory) whenever you view the list of group pages there is a "Copy page" button next to any which are copyable. However, blocktype/groupviews/groupviews.json.php doesn't import pieforms, meaning it fails when trying to create the button. So the simple fix is to require pieforms in that page.

Changed in mahara:
importance: Undecided → Medium
Jono Mingard (mingard) on 2015-05-15
Changed in mahara:
assignee: nobody → Jono Mingard (mingard)
status: Confirmed → In Progress
Robert Lyon (robertl-9) on 2015-05-17
Changed in mahara:
milestone: none → 15.10.0
status: In Progress → Fix Committed
Son Nguyen (ngson2000) wrote :

Other things need to be fixed is the inconsistency of getting data in blocktype/groupviews/lib.php and blocktype/groupviews/groupviews.json.php with sortoptions

Changed in mahara:
status: Fix Committed → In Progress
Aaron Wells (u-aaronw) wrote :
Aaron Wells (u-aaronw) wrote :

Patch for 15.04_STABLE: https://reviews.mahara.org/#/c/4767/

Aaron Wells (u-aaronw) wrote :

Reviewed: https://reviews.mahara.org/4768
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/954fee81b0cfc1e5dfbc57a3a75c00d4781e48bc
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.10_STABLE

commit 954fee81b0cfc1e5dfbc57a3a75c00d4781e48bc
Author: Jono Mingard <email address hidden>
Date: Fri May 15 15:53:27 2015 +1200

Add pieforms to groupviews JSON renderer (Bug #1454458)

Ensures that pieform() is defined so that a "copy page" button can
be created for copyable pages

Change-Id: I2228ddfde04747a53b173a168d92286fc33af048
(cherry picked from commit b9839b52ee0b47ee0203c6c1f545f62d38721170)

Aaron Wells (u-aaronw) on 2015-05-19
Changed in mahara:
status: In Progress → Fix Committed
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4767
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/b9fb49ad521c456633d308c98b406e7f0f83ae8c
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit b9fb49ad521c456633d308c98b406e7f0f83ae8c
Author: Jono Mingard <email address hidden>
Date: Fri May 15 15:53:27 2015 +1200

Add pieforms to groupviews JSON renderer (Bug #1454458)

Ensures that pieform() is defined so that a "copy page" button can
be created for copyable pages

Change-Id: I2228ddfde04747a53b173a168d92286fc33af048
(cherry picked from commit b9839b52ee0b47ee0203c6c1f545f62d38721170)

Robert Lyon (robertl-9) on 2016-11-06
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers