Include PHP version in mahara.org stats

Bug #1447865 reported by Aaron Wells on 2015-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Unassigned
1.10
High
Unassigned
1.9
High
Unassigned
15.04
High
Unassigned
15.10
High
Unassigned

Bug Description

We were discussing at the last developer meeting, the possibility of raising our supported PHP version to 5.4. But, we don't really have any idea how many sites out there are currently on PHP 5.3.

So we decided that we should add the PHP version to the usage data people voluntarily send back to mahara.org through the cron_send_registration_data() method.

In order to make this decision in a timely manner to inform 15.10, we'll need to include this change in the next minor version update.

Aaron Wells (u-aaronw) on 2015-04-24
Changed in mahara:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Aaron Wells (u-aaronw)
Aaron Wells (u-aaronw) wrote :

While I'm at it, I'm also going to collect information about the database version ("select version()"), the OS (php_uname()), the SAPI (php_sapi_name()), and the versions/absence of all the PHP modules listed in Mahara's README.

I was going to also include the webserver version, but I've just realized that this data is collected by the cron, which is usually run as a CLI script, so $_SERVER won't be populated.

Hm, although I guess some people do execute the cron via the web URL as well. I guess I'll look for $_SERVER['SERVER_SOFTWARE'], and if it's present I'll include it.

Aaron Wells (u-aaronw) wrote :

Another possibility would be to fire a cURL request at the site itself, but that strikes me as too buggy to be worth doing.

Aaron Wells (u-aaronw) wrote :

Testing instructions:

The easiest way to test this is to use the "Registration" page to preview the data that will be sent out to mahara.org.

1. Clean install of Mahara
2. Log in as admin
3. Go to Administration -> Register
4. Expand the "Data that will be sent" fieldset

Expected result: In the list of items that will be sent, you should see these new fields:

phpversion, dbversion, osversion, phpsapi, webserver, phpmodules

Aaron Wells (u-aaronw) wrote :

I have also implemented and deployed a change to mahara.org to tell it to accept the new information fields.

tags: added: needs-behat
Robert Lyon (robertl-9) wrote :

One thing I notice is the php modules string does not wrap when viewing it on admin/registersite.php

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4720

tags: added: has-behat
removed: needs-behat
Aaron Wells (u-aaronw) wrote :

Oh, maybe we should put spaces between the module names so that they'll wrap better.

Aaron Wells (u-aaronw) wrote :

I've filed a separate Bug 1450334 to cover adding a re-confirmation step, because the data that is being sent has changed.

Once we get that implemented, I would also like to backport this change to all the currently supported releases, so that we can start gathering data immediately, instead of waiting years for people to upgrade to 15.10.

Aaron Wells (u-aaronw) wrote :

Marking as "Incomplete" for the older releases, because this shouldn't be backported until we have a patch for Bug 1450334.

Reviewed: https://reviews.mahara.org/4696
Committed: http://gitorious.org/mahara/mahara/commit/5fa788c0408b1148d29129d016eae438cdf24296
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 5fa788c0408b1148d29129d016eae438cdf24296
Author: Aaron Wells <email address hidden>
Date: Fri Apr 24 15:57:34 2015 +1200

Adding PHP & system info to stats collection

Bug 1447865

Change-Id: Ia4b09ff1bf379421f1fc1b77de07d86353569452

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4720
Committed: http://gitorious.org/mahara/mahara/commit/78b542723d71551b9d3786368c15cca2dde95c23
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 78b542723d71551b9d3786368c15cca2dde95c23
Author: Jinelle Foley-Barnes <email address hidden>
Date: Thu Apr 30 16:58:34 2015 +1200

Behat Test: Registered data (Bug 1447865)

Feel free to make the feature better, I struggled to word this one.

Change-Id: Iad24470cf47ddae1fa100cbef06e3624bd2652e2

Mahara Bot (dev-mahara) wrote :

Patch for "1.10_STABLE" branch: https://reviews.mahara.org/5126

Robert Lyon (robertl-9) wrote :

Will need derivatives of patch https://reviews.mahara.org/#/c/5111/1 for the other branches

Reviewed: https://reviews.mahara.org/5125
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/b6f1536e455e3df3c32a6e60d0c09de545f4dbef
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit b6f1536e455e3df3c32a6e60d0c09de545f4dbef
Author: Aaron Wells <email address hidden>
Date: Fri Apr 24 15:57:34 2015 +1200

Adding PHP & system info to stats collection

Bug 1447865

Change-Id: Ia4b09ff1bf379421f1fc1b77de07d86353569452
(cherry picked from commit 5fa788c0408b1148d29129d016eae438cdf24296)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5127
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/c7139c0c730ff476c9f105849bc90a9b6ff8e0ff
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.9_STABLE

commit c7139c0c730ff476c9f105849bc90a9b6ff8e0ff
Author: Aaron Wells <email address hidden>
Date: Fri Apr 24 15:57:34 2015 +1200

Adding PHP & system info to stats collection

Bug 1447865

Change-Id: Ia4b09ff1bf379421f1fc1b77de07d86353569452
(cherry picked from commit 5fa788c0408b1148d29129d016eae438cdf24296)

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5126
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/f7715d16768991c8907579013d77bd2d850610ac
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit f7715d16768991c8907579013d77bd2d850610ac
Author: Aaron Wells <email address hidden>
Date: Fri Apr 24 15:57:34 2015 +1200

Adding PHP & system info to stats collection

Bug 1447865

Change-Id: Ia4b09ff1bf379421f1fc1b77de07d86353569452
(cherry picked from commit 5fa788c0408b1148d29129d016eae438cdf24296)

Robert Lyon (robertl-9) on 2016-11-06
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments