Add anchor button to tinymce

Bug #1446400 reported by Robert Lyon on 2015-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Liam

Bug Description

One of the useful tinyMCE buttons that we currently do not use is the Anchor button to allow one to add anchors to a block of text.

It should be a matter of adding 'anchor' to the plugins and toolbar sections of lib/web.php

and then testing it out to make sure it works as expected

Aaron Wells (u-aaronw) wrote :

To expand on what Robert said, the "anchor" plugin ships with TinyMCE, and thus with Mahara (it's under htdocs/js/tinymce/plugins/anchor). But we just haven't been activating it.

Aaron Wells (u-aaronw) wrote :

Hm, maybe we should add a local/lib.php method to let people customize the TinyMCE buttons. Because I can see how, for instance, on mahara.org it would be handy to have the "code" plugin enabled also, but probably most Mahara sites wouldn't care about that one.

Changed in mahara:
importance: Low → Wishlist
Aaron Wells (u-aaronw) on 2015-09-30
Changed in mahara:
milestone: 15.10.0 → 16.04.0
Aaron Wells (u-aaronw) on 2016-04-28
Changed in mahara:
milestone: 16.04.0 → 16.10.0
Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0
Changed in mahara:
milestone: 17.04.0 → none
Liam (liam-sharpe) on 2018-01-30
Changed in mahara:
assignee: nobody → Liam (liam-sharpe)
status: Confirmed → In Progress
Changed in mahara:
milestone: none → 18.04.0

Reviewed: https://reviews.mahara.org/8485
Committed: https://git.mahara.org/mahara/mahara/commit/099b3d3119a1e9900ab2ea2341470d15f05adbe3
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 099b3d3119a1e9900ab2ea2341470d15f05adbe3
Author: Liam <email address hidden>
Date: Wed Jan 31 10:29:47 2018 +1300

Bug #1446400: Add anchor button to tinymce

behatnotneeded

Change-Id: I6f2b26e6bb9e839e8c3ccaddef6fdfc916b3bdd9

Robert Lyon (robertl-9) on 2018-02-14
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers