"Unsubscribe" link for feedback notifications due to watchlist

Bug #1443284 reported by Aaron Wells on 2015-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Unassigned

Bug Description

As described on Bug 1374674: https://bugs.launchpad.net/mahara/+bug/1374674/comments/9

Users receive notifications when there are comments on pages that are on their watchlist. If they receive this notification by email, we should add a link to the bottom of the email explaining that they received the email because the page is on their watchlist, and telling them to unwatch the page if they want to unsubscribe.

For that matter, it would also be good if the inbox notification for feedback on watched pages could also indicate this in some way. But with the current inbox design, it would not be easy to add that.

Aaron Wells (u-aaronw) on 2015-10-23
Changed in mahara:
milestone: 15.10.0 → 16.04.0
Aaron Wells (u-aaronw) wrote :

This one's marked as a "Medium" rather than "Wishlist", because email best-practice is to always give users an easy way to disable future automated emails.

no longer affects: mahara/15.10
no longer affects: mahara/16.04
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0
no longer affects: mahara/16.10
Changed in mahara:
milestone: 17.04.0 → 17.10.0
Robert Lyon (robertl-9) on 2017-09-19
Changed in mahara:
milestone: 17.10.0 → 18.04.0
Robert Lyon (robertl-9) wrote :

Bumping this to high as we should get around to fixing this problem sooner rather than later

Changed in mahara:
importance: Medium → High
Robert Lyon (robertl-9) on 2017-11-01
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/8251
Committed: https://git.mahara.org/mahara/mahara/commit/17131a35785e8cb0654a61d03eeb407557b0ad38
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 17131a35785e8cb0654a61d03eeb407557b0ad38
Author: Robert Lyon <email address hidden>
Date: Wed Nov 1 14:26:02 2017 +1300

Bug 1443284: Allow an unsubscribe link for watchlist emails

This patch:
- adds an 'unsubscribetoken' column to usr_watchlist_view table
(if we want to unsubscribe other messages we'd need to add an
'unsubscribetoken' to the relevant table)
- records the token when one watches the view
- sends email with unsubscribe link with message type and token to
avoid exposing any user data
- link goes to unsubscribe.php page and either unsubscribes user or
gives generic warning

Currently only working for watchlist notifications being sent via
email/email digest

Change-Id: I823249108f521faaefe3435f03b84ddf73e2d360
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2018-03-02
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2018-04-05
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers