Be able to send a message when approving new user account

Bug #1440617 reported by Kristina Hoeppner on 2015-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Unassigned

Bug Description

Since we turned on registration on mahara.org, I've been approving accounts and then sending separate emails to give some more details, e.g. approving a legimitate account but wanting to point to the user manual, or where they can find out more about getting Mahara hosted.

It would be good to be able to send that as part of the registration in a approval message. When you deny a registration, you can provide a reason. The same should be true for account approval and the admin should have a text field available that they can use for an individualized email message.

Changed in mahara:
status: New → Confirmed
tags: added: bite-sized
Steven (stevens-q) wrote :

Environment tested: Master
Browser tested: Chrome

PRECONDITIONS:
------------------------
1) "Institution One" exists
--- a) Registration has been allowed for this institution
--- b) Confirm registration has been set to yes
2) New users have requested registration for Institution One
--- a) all new registers have an email as follows steven+<number>@catalyst.net.nz
3) Notification settings for the site have been all set to inbox

TEST STEPS:
------------------------
1) Log in as Institution admin
2) Confirm that admin user / Inst admin have a notification in their inbox - indicating a new registration ✘
3) Browse to Admin menu > Institutions > Pending registrations
4) Confirm a list of new registrations are listed in a table ✔
5) Confirm each new register has an option of either "Approve" or "Deny" ✔
6) Click the "Deny" button
7) Confirm a modal window is displayed with
--- a) a "Denial reason" field ✔
--- b) a "Deny" submit button ✔
--- c) a "Cancel" link to go back to previous step ✔
8) Fill in the required field and click the "Deny" button
9) Confirm the following
--- a) the modal window closes and user is on the Pending registrations page ✔
---b) the user has been removed from the list of pending registers ✔
---c) the pending register receives an email with the reason for denial ✘
10) Select another user from the pending users list and click the "Approve" button
11) Confirm a modal window is displayed with
--- a) a "Denial reason" field ✔
--- b) a "Deny" submit button ✔
--- c) a "Cancel" link to go back to previous step
12) Fill in the required field and click the "Approve" button
13) Confirm the following
--- a) the modal window closes and user is on the Pending registrations page ✔
--- b) the Approve and Deny buttons are not displayed ✔
--- c) a message of "Approval sent, waiting on user completion" is displayed where the buttons used to be ✔
--- d) the pending register receives an email with the reason for approval ✘

Catalyst QA Failed Testing ✘

NOTE: I am not receiving emails for pending users or notifications in inbox of admin users about users who wish to register. I do get notifications in my in box for friend requests and group invitations.

Lisa Seeto (lisaseeto) wrote :

This is strange as I'm definitely getting emails. I get emails when a pending user wishes to register and I get emails when a registration has been either approved or denied. I was chatting with Bob yesterday who said that there weren't supposed to be any email notifications in the inbox for these type of emails- I will double check.

Steven (stevens-q) wrote :

Emails have been received for both approve and deny registration request see attached screenshots

Catalyst QA Approved ✔

Steven (stevens-q) wrote :
Robert Lyon (robertl-9) on 2019-02-06
Changed in mahara:
milestone: none → 19.04.0
status: Confirmed → Fix Committed
tags: added: nominatedfeature
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers