Changing view layout causes an error

Bug #1432641 reported by Olli Puurunen on 2015-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Son Nguyen
1.10
High
Unassigned
1.9
High
Unassigned
15.04
High
Son Nguyen
15.10
High
Unassigned

Bug Description

Steps to reproduce:

1. Create a new view
2. Select the layout with one column in first row and three columns in second
3. Add two textboxes to each column, 8 textboxes total
4. Change the layout to one row & one column

This results in following error:

[WAR] d1 (lib/dml.php:890) Failed to get a recordset: mysqli error: [1062: Duplicate entry '593-2-1-0' for key 'blocinst_vierowcolord_uk'] in adodb_throw(UPDATE "block_instance" SET "order" = 0 WHERE "order" = '1' AND "view" = '593' AND "row" = '2' AND "column" = 1, )
Command was: UPDATE "block_instance" SET "order" = ? WHERE "order" = ? AND "view" = ? AND "row" = ? AND "column" = ? and values was (0,1,593,2,1)

Tested in 1.9.1 (Ubuntu 14.04.2 / MySQL 5.5.35 / Chrome 41.0.2272.89 (64-bit)) and Mahara Demo (currently 1.10).

Robert Lyon (robertl-9) on 2015-03-19
Changed in mahara:
status: New → Confirmed
importance: Undecided → High
Son Nguyen (ngson2000) on 2015-03-26
Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/4527
Committed: http://gitorious.org/mahara/mahara/commit/748538e3c430bd660ceb565255753a34b0c162ed
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 748538e3c430bd660ceb565255753a34b0c162ed
Author: Son Nguyen <email address hidden>
Date: Tue Mar 31 07:34:04 2015 +1300

Fix bugs when changing view layout. Bug 1432641

Change-Id: I0ae87e94bd7ad723a19045598280a6c4880aa3d8
Signed-off-by: Son Nguyen <email address hidden>

Robert Lyon (robertl-9) on 2015-03-30
Changed in mahara:
milestone: none → 15.04.0
status: In Progress → Fix Committed

Reviewed: https://reviews.mahara.org/4537
Committed: http://gitorious.org/mahara/mahara/commit/ccd48aa2a07d27169f29204875a8d8a571a69549
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit ccd48aa2a07d27169f29204875a8d8a571a69549
Author: Son Nguyen <email address hidden>
Date: Tue Mar 31 07:34:04 2015 +1300

Fix bugs when changing view layout. Bug 1432641

Change-Id: I0ae87e94bd7ad723a19045598280a6c4880aa3d8
Signed-off-by: Son Nguyen <email address hidden>

Reviewed: https://reviews.mahara.org/4629
Committed: http://gitorious.org/mahara/mahara/commit/b4a4e5dc6ac834efde21f7e806c2c93a39746189
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.10_STABLE

commit b4a4e5dc6ac834efde21f7e806c2c93a39746189
Author: Son Nguyen <email address hidden>
Date: Tue Mar 31 07:34:04 2015 +1300

Fix bugs when changing view layout. Bug 1432641

Change-Id: I0ae87e94bd7ad723a19045598280a6c4880aa3d8
Signed-off-by: Son Nguyen <email address hidden>

Reviewed: https://reviews.mahara.org/4630
Committed: http://gitorious.org/mahara/mahara/commit/7d793f279183e5e9b27391d5526fde78f6a88656
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.9_STABLE

commit 7d793f279183e5e9b27391d5526fde78f6a88656
Author: Son Nguyen <email address hidden>
Date: Tue Mar 31 07:34:04 2015 +1300

Fix bugs when changing view layout. Bug 1432641

Change-Id: I0ae87e94bd7ad723a19045598280a6c4880aa3d8
Signed-off-by: Son Nguyen <email address hidden>

Aaron Wells (u-aaronw) wrote :

Running a quick test, it turns out this problem is present from 1.8 on. I've backported the fix to 1.10 and 1.9. The patch didn't apply cleanly to 1.8, so I'm not going to backport there, since we're so close to the end of support for 1.8.

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
Son Nguyen (ngson2000) on 2015-04-19
no longer affects: mahara/1.8
tags: added: behat needs-behat
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers