Display Problem on the page exported HTML "Profile Information"

Bug #1429883 reported by issam.taboubi on 2015-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
issam.taboubi
1.10
Medium
Unassigned

Bug Description

Here some instructions to reproduce the bug :
 - login as admin
 - create a new user with basic informations
 - logout and login with this new user
- export the portfolio as HTML
- download the Zip and Unzip
- go the index page and click View all profile information
- you should see 'Last name: Array' ( see the screenshot )

on master

issam.taboubi (issam-tab) wrote :
tags: added: export
Changed in mahara:
assignee: nobody → issam.taboubi (issam-tab)

Reviewed: https://reviews.mahara.org/4372
Committed: http://gitorious.org/mahara/mahara/commit/29b9b1f83ede2698e967b0ada08220d4b071f22c
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 29b9b1f83ede2698e967b0ada08220d4b071f22c
Author: taboubi <email address hidden>
Date: Mon Mar 9 11:33:49 2015 -0400

HTML Export profile info showing as 'array()' (Bug #1429883)

If user has no socialprofile info set it makes the previous profile value equal 'array()'

Change-Id: Ia6260f63349f43d0a40458f18e25ef2d7c23497d

Robert Lyon (robertl-9) wrote :

Hi issam.taboubi for your patch.

I've tested it out and have verified it fixes the problem - and have merged the patch.

Cheers

Robert

Changed in mahara:
milestone: none → 15.04.0
importance: Undecided → Medium
status: New → Fix Committed
Aaron Wells (u-aaronw) wrote :

I encountered the same issue in Mahara 1.10, except that it was the Email address that showed "Array".

Reviewed: https://reviews.mahara.org/4374
Committed: http://gitorious.org/mahara/mahara/commit/197eacef060e1a21bb53ab50000cbb71e1e56957
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.10_STABLE

commit 197eacef060e1a21bb53ab50000cbb71e1e56957
Author: taboubi <email address hidden>
Date: Mon Mar 9 11:33:49 2015 -0400

HTML Export profile info showing as 'array()' (Bug #1429883)

If user has no socialprofile info set it makes the previous profile value equal 'array()'

Change-Id: Ia6260f63349f43d0a40458f18e25ef2d7c23497d

Aaron Wells (u-aaronw) wrote :

Verified that the problem isn't present in 1.9.

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers