Hanging when trying to export as a Standalone HTML website

Bug #1417319 reported by Jinelle Foley-Barnes on 2015-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Aaron Wells

Bug Description

Hi,

When I was testing using: git fetch https://reviews.mahara.org/mahara refs/changes/03/3903/2 && git checkout FETCH_HEAD

I went to Portfolio -> Export -> and then exported as a standalone HTML website it filled most of the status bar green and then just hung and never completed.

This was also tested on another machine and the same result occured.

Mahara 15.04 9 ( see specific patch above)
psql (PostgreSQL) 9.3.5
Firefox 35.0.1
Ubuntu 14.04

Thanks,
Jinelle

Aaron Wells (u-aaronw) wrote :

I replicated this on 15.04dev HEAD. It throws this warning:

[WAR] f9 (lib/file.php:812) dir(/home/aaronw/www/mahara/htdocs/artefact//artefact/file/export/html/static/): failed to open dir: No such file or directory
Call stack (most recent first):

    log_message("dir(/home/aaronw/www/mahara/htdocs/artefact//artef...", 8, true, true, "/home/aaronw/www/mahara/htdocs/lib/file.php", 812) at /home/aaronw/www/mahara/htdocs/lib/errors.php:441
    error(2, "dir(/home/aaronw/www/mahara/htdocs/artefact//artef...", "/home/aaronw/www/mahara/htdocs/lib/file.php", 812, array(size 2)) at Unknown:0
    dir("/home/aaronw/www/mahara/htdocs/artefact//artefact/...") at /home/aaronw/www/mahara/htdocs/lib/file.php:812
    copyr("/home/aaronw/www/mahara/htdocs/artefact//artefact/...", "/home/aaronw/dataroot/mahara/export/1/1422936422//...") at /home/aaronw/www/mahara/htdocs/export/html/lib.php:507
    PluginExportHtml->copy_static_files() at /home/aaronw/www/mahara/htdocs/export/html/lib.php:205
    PluginExportHtml->export() at /home/aaronw/www/mahara/htdocs/export/download.php:98

Changed in mahara:
importance: Medium → High
status: New → In Progress
assignee: nobody → Aaron Wells (u-aaronw)
Aaron Wells (u-aaronw) wrote :

Okay, so this error reached its current form in commit bd44670666105642dd9b09eb06fc312884bc1e46. But the commit before that is broken too, it just shows "No pieform template available: wallpost.php Continue" instead.

Aaron Wells (u-aaronw) wrote :

Unsurprisingly, the first commit that broke this is the one where I relocated all the theme files:

commit 89e4609b3e6c671637ca7bc601ab445d9cc75af2
Author: Aaron Wells <email address hidden>
Date: Wed Oct 22 16:32:03 2014 +1300

    Bug 1383995: Move plugin files into the /theme directory

    Theme files for plugins can now live under the plugin's directory or under
    the theme's directory. Moving the files for the core plugins to /theme
    should make life easier for theme developers by putting them all in one place.

    Change-Id: Icff863c46c80ed2d6be07cd49404bc0b7f5fc4c0

Aaron Wells (u-aaronw) wrote :

Ah, the problem is that PluginExportHtml::copy_static_files() duplicates the logic from Theme->_get_path() (in lib/web.php), but we didn't update it both places.

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4302

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4369

Reviewed: https://reviews.mahara.org/4302
Committed: http://gitorious.org/mahara/mahara/commit/f7b443c7f423879cabaa190bd8d953b6fa085f0d
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit f7b443c7f423879cabaa190bd8d953b6fa085f0d
Author: Robert Lyon <email address hidden>
Date: Mon Feb 23 14:20:39 2015 +1300

HTML export to use new path to plugin templates (Bug #1417319)

- also updated the location of the file/folder icons so that one can
test/verify this patch.

Note: this patch doesn't fix all the problems of html export but does
fix the regression of where the html export would never complete

Change-Id: I8096e82cfde3dd2f060a05cc6157b201306089e6
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4303
Committed: http://gitorious.org/mahara/mahara/commit/a3eea7b115ec9339cb5977a24953ff38cdf810de
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit a3eea7b115ec9339cb5977a24953ff38cdf810de
Author: Robert Lyon <email address hidden>
Date: Mon Apr 13 14:12:35 2015 +1200

Exporting to html was creating pages with ajaxify blocks (Bug #1417319)

Discovered this problem when I fixed the HTML export - it was
exporting blocks with the loading spinner rather than actual block
content

Change-Id: Id9c790f7cc6058141fb98c6d984af188ae265d6c
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4632
Committed: http://gitorious.org/mahara/mahara/commit/055e4be8ed60e5a02a53b473908d010633cc98e0
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 055e4be8ed60e5a02a53b473908d010633cc98e0
Author: Robert Lyon <email address hidden>
Date: Mon Apr 13 14:12:35 2015 +1200

Exporting to html was creating pages with ajaxify blocks (Bug #1417319)

Discovered this problem when I fixed the HTML export - it was
exporting blocks with the loading spinner rather than actual block
content

Change-Id: Id9c790f7cc6058141fb98c6d984af188ae265d6c
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers