Change default "You are logged in from" text

Bug #1413547 reported by Gordon McLeod on 2015-01-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
Low
Aaron Wells

Bug Description

Usability Enhancement
Hello,
I've thought this could be better worded for years but I'm only now getting around to submiting a request. When signing into Mahara via a linked Moodle a line of text is displayed beside the user profile picture that says "You are logged in from Moodle". This would be much more user friendly - and give people an indication of what the link actually does - if instead it said "Return to Moodle", making it contextual.

I know that it's possible to edit the code to make this change - but not every site admin is willing to alter core code (I'm not permitted to at my current institution), so I'm suggesting that this would be a useful change to make to core.

Thanks, Gordon.

Aaron Wells (u-aaronw) on 2015-02-13
tags: added: mnet usability
Changed in mahara:
milestone: none → 15.04.0
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Aaron Wells (u-aaronw)
Aaron Wells (u-aaronw) wrote :

Hi Gordon,

Thanks for the suggestion! I've pushed this into our code review system: https://reviews.mahara.org/4275

Currently the message is "You are logged in from <institution>", so changing that to "Return to <institution>" didn't really make sense, because it doesn't tell you that you're going back to a Moodle site.

So in addition to changing the text to "Return to..." I've also replaced the institution name with the sitename from the XMLRPC configuration dialogue. So now it reads "Return to <Moodle site name>".

Cheers,
Aaron

Reviewed: https://reviews.mahara.org/4275
Committed: http://gitorious.org/mahara/mahara/commit/999e0bcd81d8cca35bb01bc1b23e947ff3e06b4a
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 999e0bcd81d8cca35bb01bc1b23e947ff3e06b4a
Author: Aaron Wells <email address hidden>
Date: Fri Feb 13 14:40:01 2015 +1300

Change MNet backnav link text to say "Return to <sitename>"

Bug 1413547

Change-Id: I8651c35de876ff4c5ddd686792d0a0ccf5195bcf

Robert Lyon (robertl-9) on 2015-02-19
Changed in mahara:
status: Confirmed → Fix Committed
tags: added: usermanualupdate
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers